gnu: Separate Python core packages from the rest.
[jackhill/guix/guix.git] / gnu / packages / nutrition.scm
index 0e03253..0e55334 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,7 +28,8 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages image)
-  #:use-module (gnu packages python))
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz))
 
 (define-public gourmet
   (package
@@ -62,9 +64,9 @@
        (modify-phases %standard-phases
          (replace 'install
            (lambda* (#:key make-flags #:allow-other-keys)
-             (zero? (system* "python" "setup.py" "install" "--prefix"
-                             (assoc-ref %outputs "out"))))))))
-    (home-page "http://thinkle.github.io/gourmet/")
+             (invoke "python" "setup.py" "install" "--prefix"
+                     (assoc-ref %outputs "out")))))))
+    (home-page "https://thinkle.github.io/gourmet/")
     (synopsis "Recipe organizer")
     (description
      "Gourmet Recipe Manager is a recipe organizer that allows you to collect,