gnu: freeipmi: Update to 1.4.10.
[jackhill/guix/guix.git] / gnu / packages / bdw-gc.scm
index b223721..6615891 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages pkg-config))
 
-(define-public libgc
+(define-public libgc-7.2
   (package
    (name "libgc")
-   (version "7.2d")
+   (version "7.2f")
    (source (origin
             (method url-fetch)
-            (uri (string-append
-                  "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
-                  version ".tar.gz"))
+            (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
+                                version ".tar.gz"))
             (sha256
              (base32
-              "0phwa5driahnpn79zqff14w9yc8sn3599cxz91m78hqdcpl0mznr"))))
+              "119x7p1cqw40mpwj80xfq879l9m1dkc7vbc1f3bz3kvkf8bf6p16"))))
    (build-system gnu-build-system)
    (arguments
     ;; Make it so that we don't rely on /proc.  This is especially useful in
@@ -58,23 +58,22 @@ simple collector interface.
 
 Alternatively, the garbage collector may be used as a leak detector for
 C or C++ programs, though that is not its primary goal.")
-   (home-page "http://www.hpl.hp.com/personal/Hans_Boehm/gc/")
+   (home-page "http://www.hboehm.info/gc/")
 
-   (license
-    (x11-style "http://www.hpl.hp.com/personal/Hans_Boehm/gc/license.txt"))))
+   (license (x11-style (string-append home-page "license.txt")))))
 
 (define-public libatomic-ops
   (package
     (name "libatomic-ops")
-    (version "7.4.0")
+    (version "7.4.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/libatomic_ops-"
+                    "http://www.ivmaisoft.com/_bin/atomic_ops/libatomic_ops-"
                     version ".tar.gz"))
               (sha256
                (base32
-                "0njv3n63zw6v45k68z6dz14g2hpk5p230ncwmdfkglsljb1cqx98"))))
+                "1pdm0h1y7bgkczr8byg20r6bq15m5072cqm5pny4f9crc9gn3yh4"))))
     (build-system gnu-build-system)
     (outputs '("out" "debug"))
     (synopsis "Accessing hardware atomic memory update operations")
@@ -83,22 +82,21 @@ C or C++ programs, though that is not its primary goal.")
 memory update operations on a number architectures.  These might allow you to
 write code that does more interesting things in signal handlers, write
 lock-free code, experiment with thread programming paradigms, etc.")
-    (home-page "http://www.hpl.hp.com/research/linux/atomic_ops/")
+    (home-page "https://github.com/ivmai/libatomic_ops/")
 
     ;; Some source files are X11-style, others are GPLv2+.
     (license gpl2+)))
 
-(define-public libgc-7.4
-  (package (inherit libgc)
-    (version "7.4.0")
+(define-public libgc
+  (package (inherit libgc-7.2)
+    (version "7.4.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-"
-                    version ".tar.gz"))
+              (uri (string-append "http://www.hboehm.info/gc/gc_source/gc-"
+                                  version ".tar.gz"))
               (sha256
                (base32
-                "10z2nph62ilab063wygg2lv0jxlsbcf2az9w1lx01jzqj5lzry31"))))
+                "18mg28rr6kwr5clc65k4l4hkyy4kd16amx831sjf8q2lqkbhlck3"))))
 
     ;; New dependencies.
     (native-inputs `(("pkg-config" ,pkg-config)))