gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / cpio.scm
index 6fddc3f..58b2f45 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18,7 +19,8 @@
 
 (define-module (gnu packages cpio)
   #:use-module (guix licenses)
-  #:use-module (distro)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 (define-public cpio
   (package
     (name "cpio")
-    (version "2.11")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/cpio/cpio-"
-                          version ".tar.bz2"))
-      (sha256
-       (base32
-        "1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))))
+    (version "2.13")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/cpio/cpio-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:patches (list (assoc-ref %build-inputs
-                                  "patch/gets"))))
-    (inputs
-     `(("patch/gets" ,(search-patch "cpio-gets-undeclared.patch"))))
     (home-page "https://www.gnu.org/software/cpio/")
-    (synopsis
-     "A program to create or extract from cpio archives")
+    (synopsis "Manage cpio and tar file archives")
     (description
-     "GNU Cpio copies files into or out of a cpio or tar archive. The
-archive can be another file on the disk, a magnetic tape, or a pipe.
-
-GNU Cpio supports the following archive formats: binary, old ASCII, new
-ASCII, crc, HPUX binary, HPUX old ASCII, old tar, and POSIX.1 tar. The
-tar format is provided for compatability with the tar program. By
-default, cpio creates binary format archives, for compatibility with
-older cpio programs. When extracting from archives, cpio automatically
-recognizes which kind of archive it is reading and can read archives
-created on machines with a different byte-order.")
-    (license gpl3+)))
\ No newline at end of file
+     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
+many formats are supported, including legacy formats.  The format is
+determined automatically by the program and is handled appropriately.
+Furthermore, the location of the archive is not important.  It can be another
+file on the drive, a tape, or data on a pipe.")
+    (license gpl3+)))