gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / indent.scm
index eb42e6a..bd36f7b 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17,8 +18,8 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages indent)
-  #:use-module (distro)
-  #:use-module (guix licenses)
+  #:use-module (gnu packages)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
             (sha256 (base32
                      "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
    (build-system gnu-build-system)
-   (synopsis "GNU Indent, a program for code indentation and formatting")
+   (arguments
+    `(#:phases (alist-cons-after
+                'unpack 'fix-docdir
+                (lambda _
+                  ;; Although indent uses a modern autoconf in which docdir
+                  ;; defaults to PREFIX/share/doc, the doc/Makefile.am
+                  ;; overrides this to be in PREFIX/doc.  Fix this.
+                  (substitute* "doc/Makefile.in"
+                    (("^docdir = .*$") "docdir = @docdir@\n")))
+                %standard-phases)))
+   (synopsis "Code reformatter")
    (description
-    "GNU Indent can be used to make code easier to read. It can also convert
-from one style of writing C to another. Indent understands a substantial
-amount about the syntax of C, but it also attempts to cope with incomplete
-and misformed syntax. The GNU style of indenting is the default.")
-   (license gpl3+)
+    "Indent is a program that makes source code easier to read by
+reformatting it in a consistent style.  It can change the style to one of
+several different styles such as GNU, BSD or K&R.  It has some flexibility to
+deal with incomplete or malformed syntax.  GNU indent offers several
+extensions over the standard utility.")
+   (license license:gpl3+)
    (home-page "http://www.gnu.org/software/indent/")))