Synchronize package descriptions with the Womb.
[jackhill/guix/guix.git] / gnu / packages / gperf.scm
index 94fa62b..d9e8033 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,7 +20,6 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public gperf
     (build-system gnu-build-system)
     (arguments '(#:parallel-tests? #f))
     (home-page "http://www.gnu.org/software/gperf/")
-    (synopsis
-     "GNU gperf, a perfect hash function generator")
+    (synopsis "Perfect hash function generator")
     (description
-     "GNU gperf is a perfect hash function generator.  For a given
-list of strings, it produces a hash function and hash table, in
-form of C or C++ code, for looking up a value depending on the
-input string.  The hash function is perfect, which means that
-the hash table has no collisions, and the hash table lookup
-needs a single string comparison only.
-
-GNU gperf is highly customizable.  There are options for
-generating C or C++ code, for emitting switch statements or
-nested ifs instead of a hash table, and for tuning the algorithm
-employed by gperf.")
+     "gperf is a perfect hash function generator.  For a given list of strings,
+it produces a hash function and hash table in C or C++ code. That the hash
+function is perfect means that no collisions can exist and that look-ups can be
+made by single string comparisons.")
     (license gpl3+)))