gnu: nnn: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / upnp.scm
index f2669f1..e7da5b3 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages)
   #:use-module (gnu packages python)
   #:use-module (guix build-system gnu)
+  #:use-module (guix utils)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix licenses)
   #:use-module (guix packages))
 
 (define-public miniupnpc
   (package
     (name "miniupnpc")
-    (version "2.0.20171212")
+    (version "2.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://miniupnp.tuxfamily.org/files/"
                            name "-" version ".tar.gz"))
        (sha256
-        (base32 "0za7pr6hrr3ajkifirhhxfn3hlhl06f622g8hnj5h8y18sp3bwff"))))
+        (base32 "1ik440yspbp3clr4m01xsl9skwyrzcvzb5nbm3i0g9x53vhbb7z1"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("python" ,python-2)))
@@ -74,3 +78,75 @@ include peer-to-peer applications, active-mode FTP clients, DCC file transfers
 over IRC, instant messaging, network games, and most server software.")
     (license
      (x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
+
+(define-public monero-miniupnpc
+  ;; This package is the bundled version of miniupnpc used with monero.
+  ;; Monero-project has been maintaining its own version of the package since
+  ;; release 0.12.2.0.  It includes security fixes not included in upstream
+  ;; releases.
+  (let ((revision "0")
+        (commit "6a63f9954959119568fbc4af57d7b491b9428d87"))
+    (package
+      (inherit miniupnpc)
+      (name "miniupnpc-monero")
+      (version (string-append "2.1-monero-0.12.3.0-" revision "."
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/monero-project/miniupnp/")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0s67zcz978iapjlq30yy9dl8qda9xhrl3jdi5f99cnbglh5gy16a"))
+                (file-name (string-append name "-" version "-checkout"))
+                (modules '((guix build utils)))
+                (snippet
+                 '(begin
+                    ;; Delete miniupnp subprojects except for miniupnpc.
+                    (for-each
+                     delete-file-recursively
+                     '("minissdpd" "miniupnpc-async" "miniupnpc-libevent"
+                       "miniupnpd" ))
+                    #t))))
+      (arguments
+       (substitute-keyword-arguments (package-arguments miniupnpc)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-before 'build 'change-directory
+               (lambda _
+                 (chdir "miniupnpc")
+                 #t))
+             (add-after 'change-directory 'chmod-header-file
+               (lambda _
+                 (chmod "miniupnpc.h" #o644)
+                 #t)))))))))
+
+(define-public libupnp
+  (package
+    (name "libupnp")
+    (version "1.6.25")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
+                          version "/" name "-" version ".tar.bz2"))
+      (sha256
+       (base32
+        "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; The tests require a network device capable of multicasting which is
+     ;; not available in the build environment. See
+     ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
+     `(#:tests? #f
+       #:configure-flags '("--enable-ipv6")))
+    (home-page "http://pupnp.sourceforge.net")
+    (synopsis "Portable SDK for UPnP Devices")
+    (description
+     "The portable SDK for UPnP Devices (libupnp) provides developers with an
+API and code for building control points, devices, and bridges that are
+compliant with Version 1.0 of the Universal Plug and Play Device Architecture
+Specification and support several operating systems like Linux, *BSD, Solaris
+and others.")
+    (license bsd-3)))