gnu: bedops: Update to 2.4.14.
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
index dbdfa22..62036d9 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17,8 +19,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages vpn)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages openssl)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xml))
 
+(define-public gvpe
+  (package
+    (name "gvpe")
+    (version "2.25")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gvpe/gvpe-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
+    (build-system gnu-build-system)
+    (home-page "http://software.schmorp.de/pkg/gvpe.html")
+    (inputs `(("openssl" ,openssl)
+              ("zlib" ,zlib)))
+    (synopsis "Secure VPN among multiple nodes over an untrusted network")
+    (description
+     "The GNU Virtual Private Ethernet creates a virtual network
+with multiple nodes using a variety of transport protocols.  It works
+by creating encrypted host-to-host tunnels between multiple
+endpoints.")
+    (license license:gpl3+)))
+
 (define-public vpnc
   (package
    (name "vpnc")
            (substitute* "Makefile"
              (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
        %standard-phases)))
-   (synopsis "vpnc, a client for cisco vpn concentrators")
+   (synopsis "Client for Cisco VPN concentrators")
    (description
     "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
-It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
+It supports IPSec (ESP) with Mode Configuration and Xauth.  It supports only
 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
-1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
+1DES, MD5, SHA1, DH1/2/5 and IP tunneling.  It runs entirely in userspace.
 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
    (license license:gpl2+) ; some file are bsd-2, see COPYING
    (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
@@ -71,36 +97,28 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
 (define-public openconnect
   (package
    (name "openconnect")
-   (version "4.99")
+   (version "7.05")
    (source (origin
             (method url-fetch)
-            (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/openconnect-"
-                                version ".tar.gz"))
+            (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
+                                "openconnect-" version ".tar.gz"))
             (sha256 (base32
-                     "1rd8pap455wzkx19i0sy3cqap524b6fwcjvqynxp6lhm01di4bd6"))))
+                     "1i102yr8yp2ny587n6pd966443h1pqxyw5q0n5afq575046jj98g"))))
    (build-system gnu-build-system)
    (inputs
-    `(("gettext" ,gnu-gettext)
-      ("libxml2" ,libxml2)
-      ("openssl" ,openssl)
-      ("pkg-config" ,pkg-config)
+    `(("libxml2" ,libxml2)
+      ("gnutls" ,gnutls)
       ("vpnc" ,vpnc)
       ("zlib" ,zlib)))
+   (native-inputs
+    `(("gettext" ,gnu-gettext)
+      ("pkg-config" ,pkg-config)))
    (arguments
-    `(#:phases
-      (alist-replace
-       'configure
-       (lambda* (#:key inputs #:allow-other-keys #:rest args)
-         (let ((vpnc (assoc-ref inputs "vpnc"))
-               (configure (assoc-ref %standard-phases 'configure)))
-           (apply configure
-                  (append args
-                          (list '#:configure-flags
-                                (list (string-append "--with-vpnc-script="
-                                                     vpnc
-                                                     "/etc/vpnc/vpnc-script")))))))
-       %standard-phases)))
-   (synopsis "client for cisco vpn")
+    `(#:configure-flags
+      `(,(string-append "--with-vpnc-script="
+                        (assoc-ref %build-inputs "vpnc")
+                        "/etc/vpnc/vpnc-script"))))
+   (synopsis "Client for Cisco VPN")
    (description
     "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
@@ -108,3 +126,33 @@ supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
 and probably others.")
    (license license:lgpl2.1)
    (home-page "http://www.infradead.org/openconnect/")))
+
+(define-public openvpn
+  (package
+    (name "openvpn")
+    (version "2.3.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://swupdate.openvpn.org/community/releases/openvpn-"
+                    version ".tar.xz"))
+              (sha256
+               (base32
+                "1v8h2nshxnvn2zyr08vzkfby1kc7ma6bi0s6hix389cj9krjxbmd"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-iproute2=yes")))
+    (native-inputs
+     `(("iproute2" ,iproute)))
+    (inputs
+     `(("lzo" ,lzo)
+       ("openssl" ,openssl)
+       ("linux-pam" ,linux-pam)))
+    (home-page "https://openvpn.net/")
+    (synopsis "Virtual private network daemon")
+    (description "OpenVPN implements virtual private network (VPN) techniques
+for creating secure point-to-point or site-to-site connections in routed or
+bridged configurations and remote access facilities.  It uses a custom
+security protocol that utilizes SSL/TLS for key exchange.  It is capable of
+traversing network address translators (NATs) and firewalls. ")
+    (license license:gpl2)))