gnu: r-org-dm-eg-db: Update to 3.5.0.
[jackhill/guix/guix.git] / gnu / packages / gkrellm.scm
index 610af41..6ad4fe6 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17,8 +18,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gkrellm)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://members.dslextreme.com/users/billw/gkrellm/gkrellm-"
+      (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-"
                           version ".tar.bz2"))
       (sha256
        (base32
         "12rc6zaa7kb60b9744lbrlfkxxfniprm6x0mispv63h4kh75navh"))))
     (build-system gnu-build-system)
     (inputs
-     `(("gettext" ,gnu-gettext)
+     `(("gettext" ,gettext-minimal)
        ("gtk+" ,gtk+-2)
        ("libice" ,libice)
        ("libsm" ,libsm)))
      `(("pkg-config" ,pkg-config)))
     (arguments
      `(#:tests? #f ; there is no check target
-       #:phases
-       (alist-delete
-        'configure
-        %standard-phases)
+       #:phases (modify-phases %standard-phases (delete 'configure))
        #:make-flags
        (let ((out (assoc-ref %outputs "out")))
          (list (string-append "INSTALLROOT=" out)
                "CC=gcc"
                "X11_LIBS = -lX11 -lSM -lICE -lgmodule-2.0"))))
-    (home-page "http://members.dslextreme.com/users/billw/gkrellm/gkrellm.html")
+    (home-page "http://gkrellm.srcbox.net/")
     (synopsis "System monitors")
     (description
      "GKrellM is a single process stack of system monitors which supports