gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / game-development.scm
index 07a1776..906d32d 100644 (file)
@@ -1092,7 +1092,7 @@ to create fully featured games and multimedia programs in the python language.")
 
 (define-public python2-pygame-sdl2
   (let ((real-version "2.1.0")
-        (renpy-version "7.4.2"))
+        (renpy-version "7.4.4"))
     (package
       (inherit python2-pygame)
       (name "python2-pygame-sdl2")
@@ -1102,7 +1102,7 @@ to create fully featured games and multimedia programs in the python language.")
          (method url-fetch)
          (uri (string-append "https://www.renpy.org/dl/" renpy-version
                              "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "1lpk69nh379x5pdlr838x5b49spzksn9hyqiq2g0q28k0xk4lm67"))
+         (sha256 (base32 "1lj5c3kfnl8s824j3hs47dg3g5rlabscmwrbb0lgpyy4633pv9ka"))
          (modules '((guix build utils)))
          (snippet
           '(begin
@@ -1145,13 +1145,13 @@ developed mainly for Ren'py.")
 (define-public python2-renpy
   (package
     (name "python2-renpy")
-    (version "7.4.2")
+    (version "7.4.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.renpy.org/dl/" version
                            "/renpy-" version "-source.tar.bz2"))
-       (sha256 (base32 "1mlrq9q3r36izyskq674qhp8s32iirvvfb4r8z6hi26189aaydsw"))
+       (sha256 (base32 "1cbbvsk1snjrsh59blb8q2h86555gi23pylmwlnk9dx0jxckdi21"))
        (modules '((guix build utils)))
        (patches
         (search-patches
@@ -1766,7 +1766,7 @@ scripted in a Python-like language.")
 (define-public entt
   (package
     (name "entt")
-    (version "3.7.0")
+    (version "3.7.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1775,7 +1775,7 @@ scripted in a Python-like language.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0nzvnhiw3r6nkmxp749zwxc8kzja09nijyxibdbri3g2i7pysf58"))))
+                "151jg3m262xwaywl2rqnc90yr6p48rhmgi5mxyv6bwqvmfli2m5p"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DENTT_BUILD_TESTING=ON"