gnu: whois: Update to 5.5.3.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
index 9d6f5bb..89547be 100644 (file)
@@ -2,6 +2,7 @@
 ;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -832,6 +833,36 @@ Disease Ontology.")
 using data from public repositories.")
     (license license:artistic2.0)))
 
+(define-public r-phastcons100way-ucsc-hg19
+  (package
+    (name "r-phastcons100way-ucsc-hg19")
+    (version "3.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "phastCons100way.UCSC.hg19"
+                              version 'annotation))
+       (sha256
+        (base32
+         "1jmc4k4zgkx5vr2plnidnd9bidlwlb0kr7mjg60cqjw7dq7jl1fa"))))
+    (properties
+     `((upstream-name . "phastCons100way.UCSC.hg19")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bsgenome" ,r-bsgenome)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-genomicscores" ,r-genomicscores)
+       ("r-iranges" ,r-iranges)
+       ("r-s4vectors" ,r-s4vectors)))
+    (home-page "https://bioconductor.org/packages/phastCons100way.UCSC.hg19")
+    (synopsis "UCSC phastCons conservation scores for hg19")
+    (description
+     "This package provides UCSC phastCons conservation scores for the human
+genome (hg19) calculated from multiple alignments with other 99 vertebrate
+species.")
+    (license license:artistic2.0)))
+
 \f
 ;;; Experiment data
 
@@ -3453,14 +3484,14 @@ profiles (GO and KEGG) of gene and gene clusters.")
 (define-public r-mlinterfaces
   (package
     (name "r-mlinterfaces")
-    (version "1.64.0")
+    (version "1.64.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "MLInterfaces" version))
        (sha256
         (base32
-         "0zqvxmvbkig3cc4r5k405s53d7y5ccvrf8kf5j6v8s1kkrklai4j"))))
+         "1c1hciwy37zpr5bzdjj2xxx2r4jdfmr5w0zmg010lm2985z41gqh"))))
     (properties `((upstream-name . "MLInterfaces")))
     (build-system r-build-system)
     (propagated-inputs
@@ -4537,14 +4568,14 @@ based on @dfn{Continuous Wavelet Transform} (CWT).")
 (define-public r-xcms
   (package
     (name "r-xcms")
-    (version "3.6.1")
+    (version "3.6.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "xcms" version))
        (sha256
         (base32
-         "06vhqvvzlkc5bslswagrapmn5ag3x84xg9gxk0fhlmgwapqwki1g"))))
+         "0icww3f1kahyk96mc07yhsbyiranzm2614n509as09jf8bdhq23v"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biobase" ,r-biobase)
@@ -5343,14 +5374,14 @@ self-organizing map clustering and minimal spanning trees.")
 (define-public r-mixomics
   (package
     (name "r-mixomics")
-    (version "6.8.4")
+    (version "6.8.5")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "mixOmics" version))
        (sha256
         (base32
-         "0lw4c9lxcm83xrvl4y120i1z710qjbdqginhrw738azpr1f82hcg"))))
+         "0s93ai5d7li8pnxd87n12j9gypvac5zfahsk68j7zjv68dglj8s7"))))
     (properties `((upstream-name . "mixOmics")))
     (build-system r-build-system)
     (propagated-inputs
@@ -6010,19 +6041,20 @@ arrays based on fast wavelet-based functional models.")
 (define-public r-variancepartition
   (package
     (name "r-variancepartition")
-    (version "1.14.0")
+    (version "1.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "variancePartition" version))
        (sha256
         (base32
-         "1ycapwb2mq57xibrzzjz9zwxqz4nwz9f3n5gskhlr5vcs7irkjd6"))))
+         "0w4kri2389x1082xppx7l6xl1a5g74fyp02iwb4938x3gzwqwbjd"))))
     (properties
      `((upstream-name . "variancePartition")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biobase" ,r-biobase)
+       ("r-biocparallel" ,r-biocparallel)
        ("r-colorramps" ,r-colorramps)
        ("r-doparallel" ,r-doparallel)
        ("r-foreach" ,r-foreach)
@@ -6047,3 +6079,61 @@ attributable to individual, tissue, time point, or technical variables.  The
 package includes dream differential expression analysis for repeated
 measures.")
     (license license:gpl2+)))
+
+(define-public r-htqpcr
+  (package
+    (name "r-htqpcr")
+    (version "1.38.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "HTqPCR" version))
+       (sha256
+        (base32
+         "09xgj797f0qsbm4jswxw7ijjwa4jxg06bfkq66xfhbvascyyrhg7"))))
+    (properties `((upstream-name . "HTqPCR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-affy" ,r-affy)
+       ("r-biobase" ,r-biobase)
+       ("r-gplots" ,r-gplots)
+       ("r-limma" ,r-limma)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)))
+    (home-page "http://www.ebi.ac.uk/bertone/software")
+    (synopsis "Automated analysis of high-throughput qPCR data")
+    (description
+     "Analysis of Ct values from high throughput quantitative real-time
+PCR (qPCR) assays across multiple conditions or replicates.  The input data
+can be from spatially-defined formats such ABI TaqMan Low Density Arrays or
+OpenArray; LightCycler from Roche Applied Science; the CFX plates from Bio-Rad
+Laboratories; conventional 96- or 384-well plates; or microfluidic devices
+such as the Dynamic Arrays from Fluidigm Corporation.  HTqPCR handles data
+loading, quality assessment, normalization, visualization and parametric or
+non-parametric testing for statistical significance in Ct values between
+features (e.g.  genes, microRNAs).")
+    (license license:artistic2.0)))
+
+(define-public r-unifiedwmwqpcr
+  (package
+    (name "r-unifiedwmwqpcr")
+    (version "1.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "unifiedWMWqPCR" version))
+       (sha256
+        (base32
+         "10j70bp5y1x2prz2iagqmwf04y79yqinq08wz4ilh8wggb9f7l8a"))))
+    (properties
+     `((upstream-name . "unifiedWMWqPCR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-htqpcr" ,r-htqpcr)))
+    (home-page "https://bioconductor.org/packages/unifiedWMWqPCR")
+    (synopsis "Unified Wilcoxon-Mann Whitney Test for differential expression in qPCR data")
+    (description
+     "This package implements the unified Wilcoxon-Mann-Whitney Test for qPCR
+data.  This modified test allows for testing differential expression in qPCR
+data.")
+    (license license:gpl2+)))