Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
index 87dc355..a01633c 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +22,7 @@
   #:use-module (guix licenses)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages guile-xyz)
   #:use-module (gnu packages lout)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages plotutils)
 (define-public skribilo
   (package
     (name "skribilo")
-    (version "0.9.3")
+    (version "0.9.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/skribilo/skribilo-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "04d8xa76jvlz25jnc6p1gzsplwcwcqrmi3f7ixdhddhl1chyz66y"))))
+               "06ywnfjfa9sxrzdszb5sryzg266380g519cm64kq62sskzl7zmnf"))))
     (build-system gnu-build-system)
     (arguments
      ;; Make the modules available under the usual location.
-     '(#:configure-flags (list (string-append "--with-guilemoduledir="
-                                              (assoc-ref %outputs "out")
-                                              "/share/guile/site/2.0"))
-
-       #:phases
+     '(#:phases
        (modify-phases %standard-phases
          (add-before 'configure 'pre-configure
            (lambda* (#:key inputs #:allow-other-keys)
@@ -57,8 +54,8 @@
                (substitute* "src/skribilo.in"
                  (("^exec (.*) -c" _ things)
                   (string-append "exec " things
-                                 " -L " reader "/share/guile/site/2.0"
-                                 " -C " reader "/share/guile/site/2.0"
+                                 " -L " reader "/share/guile/site/2.2"
+                                 " -C " reader "/lib/guile/2.2/site-ccache"
                                  " -c"))))
              #t)))
 
@@ -66,7 +63,7 @@
 
     (native-inputs `(("pkg-config" ,pkg-config)))
 
-    (inputs `(("guile" ,guile-2.0)
+    (inputs `(("guile" ,guile-2.2)
               ("imagemagick" ,imagemagick)
               ("ghostscript" ,ghostscript)        ; for 'convert'
               ("ploticus" ,ploticus)
 
     ;; The 'skribilo' command needs them, and for people using Skribilo as a
     ;; library, these inputs are needed as well.
-    (propagated-inputs `(("guile-reader" ,guile2.0-reader)
-                         ("guile-lib" ,guile2.0-lib)))
+    (propagated-inputs `(("guile-reader" ,guile-reader)
+                         ("guile-lib" ,guile-lib)))
 
-    (home-page "http://www.nongnu.org/skribilo/")
+    (home-page "https://www.nongnu.org/skribilo/")
     (synopsis "Document production tool written in Guile Scheme")
     (description
      "Skribilo is a free document production tool that takes a structured