gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libedit.scm
index 37638a2..e02c72f 100644 (file)
@@ -1,8 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public libedit
   (package
     (name "libedit")
-    (version "20191025-3.1")
+    (version "20191231-3.1")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "https://thrysoee.dk/editline"
                           "/libedit-" version ".tar.gz"))
       (sha256
-       (base32 "0fdznw6fklis39xqk30ihw8dl8kdw9fzq1z42jmbyy6lc1k07zvd"))))
+       (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
     (build-system gnu-build-system)
     (inputs
      `(("ncurses" ,ncurses)))
@@ -48,3 +49,24 @@ library (libedit).  This Berkeley-style licensed command line editor library
 provides generic line editing, history, and tokenization functions, similar to
 those found in GNU Readline.")
     (license bsd-3)))
+
+(define-public editline
+  (package
+    (name "editline")
+    (version "1.17.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
+      (sha256
+       (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
+    (build-system gnu-build-system)
+    (home-page "https://troglobit.com/projects/editline/")
+    (synopsis "Line editing library")
+    (description
+     "@code{editline} is a small line editing library.  It can be linked into almost
+any program to provide command line editing and history functions.  It is call
+compatible with the GNU Readline library, but at a fraction of the size,
+and as a result fewer features.")
+    (license bsd-4)))