gnu: celluloid: Update to 0.21.
[jackhill/guix/guix.git] / gnu / packages / fvwm.scm
index 88f6e24..6509fb3 100644 (file)
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 ng0 <ng0@n0.is>
+;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
              (let* ((out (assoc-ref outputs "out"))
                     (xsessions (string-append out "/share/xsessions")))
                (mkdir-p xsessions)
-               (with-output-to-file
-                   (string-append xsessions "/fvwm2.desktop")
-                 (lambda _
-                   (format #t
-                           "[Desktop Entry]~@
-                    Name=FVWM~@
-                    Comment=FVWM~@
-                    Exec=~a/bin/fvwm~@
-                    TryExec=~@*~a/bin/fvwm~@
-                    Icon=~@
-                    Type=Application~%"
-                           out))))
+               (make-desktop-entry-file
+                 (string-append xsessions "/fvwm2.desktop")
+                 #:name "FVWM"
+                 #:exec (string-append out "/bin/" ,name)
+                 #:comment '("FVWM")))
              #t)))))
     (native-inputs
      `(("perl" ,perl)
@@ -86,5 +79,5 @@
     (description
      "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
 window manager for the X Window system.")
-    (home-page "http://www.fvwm.org/")
+    (home-page "https://www.fvwm.org/")
     (license gpl2+)))