gnu: r-metap: Update to 1.2.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
index 733d4ec..e584a7b 100644 (file)
@@ -3072,6 +3072,35 @@ are standardized and usable by the accompanying mutossGUI package.")
     ;; Any version of the GPL.
     (license (list license:gpl2+ license:gpl3+))))
 
+;; This is a CRAN package, but it depends on mutoss, which depends on multtest
+;; from Bioconductor, so we put it here.
+(define-public r-metap
+  (package
+    (name "r-metap")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "metap" version))
+       (sha256
+        (base32
+         "0pfbcixjrzx81l9wqhlp55khg9k63zf8pvg2n39c19akr4ppzhvf"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)
+       ("r-mutoss" ,r-mutoss)
+       ("r-rdpack" ,r-rdpack)
+       ("r-tfisher" ,r-tfisher)))
+    (home-page "http://www.dewey.myzen.co.uk/meta/meta.html")
+    (synopsis "Meta-analysis of significance values")
+    (description
+     "The canonical way to perform meta-analysis involves using effect sizes.
+When they are not available this package provides a number of methods for
+meta-analysis of significance values including the methods of Edgington,
+Fisher, Stouffer, Tippett, and Wilkinson; a number of data-sets to replicate
+published results; and a routine for graphical display.")
+    (license license:gpl2)))
+
 (define-public r-triform
   (package
     (name "r-triform")