gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
index 45b7cb8..f3ab30b 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013,2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public autogen
   (package
     (name "autogen")
-    (version "5.18.5")
+    (version "5.18.12")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://gnu/autogen/rel"
-                          version "/autogen-"
-                          version ".tar.gz"))
+      (uri (string-append "mirror://gnu/autogen/rel" version
+                          "/autogen-" version ".tar.xz"))
       (sha256
        (base32
-        "1flnbnmkbqmbfgammkl8m36wrlk6rhpgnf9pdm6gdfhqalxvggbv"))))
+        "1n5zq4872sakvz9c7ncsdcfp0z8rsybsxvbmhkpbd19ii0pacfxy"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)     ;for doc generator mdoc
                      ("pkg-config" ,pkg-config)))
     (inputs `(("which" ,which)
               ("guile" ,guile-2.0)))
     (arguments
-     '(#:phases (alist-cons-before
-                 'patch-source-shebangs 'patch-test-scripts
-                 (lambda _
-                   (let ((sh (which "sh")))
-                     (substitute*
-                         (append (find-files "agen5/test" "\\.test$")
-                                 (find-files "autoopts/test" "\\.(test|in)$"))
-                       (("/bin/sh") sh)
-                       (("/usr/bin/tr") "tr"))))
-                 %standard-phases)))
-    (home-page "http://www.gnu.org/software/autogen/")
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'patch-source-shebangs 'patch-test-scripts
+           (lambda _
+             (let ((sh (which "sh")))
+               (substitute*
+                 (append (find-files "agen5/test" "\\.test$")
+                         (find-files "autoopts/test" "\\.(test|in)$"))
+                 (("/bin/sh") sh)
+                 (("/usr/bin/tr") "tr"))
+               #t))))))
+    (home-page "https://www.gnu.org/software/autogen/")
     (synopsis "Automated program generator")
     (description
      "AutoGen is a program to ease the maintenance of programs that contain