gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / jupyter.scm
index 7ec987b..f826ebd 100644 (file)
@@ -30,7 +30,6 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
-  #:use-module (gnu packages serialization)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls))
 
@@ -118,9 +117,7 @@ launching and using Jupyter kernels.")
                   (replace 'install
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))
-                             (version ((@@ (guix build python-build-system)
-                                           get-python-version)
-                                       (assoc-ref inputs "python")))
+                             (version (python-version (assoc-ref inputs "python")))
                              (pydir (string-append out "/lib/python"
                                                    version "/site-packages/"
                                                    "jupyter_kernel_test")))
@@ -148,7 +145,7 @@ Messaging Protocol}.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/QuantStack/xeus.git")
+                    (url "https://github.com/QuantStack/xeus")
                     (commit version)))
               (sha256
                (base32
@@ -170,11 +167,11 @@ Messaging Protocol}.")
        ("python-jupyter-client" ,python-jupyter-client)))
     (inputs
      `(("xtl" ,xtl)
-       ("nlohmann-json-cpp" ,nlohmann-json-cpp)
+       ("json-modern-cxx" ,json-modern-cxx)
        ("cppzmq" ,cppzmq)
        ("zeromq" ,zeromq)
        ("openssl" ,openssl)
-       ("util-linux" ,util-linux)))               ;libuuid
+       ("util-linux" ,util-linux "lib")))         ;libuuid
     (home-page "https://quantstack.net/xeus")
     (synopsis "C++ implementation of the Jupyter Kernel protocol")
     (description