Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ccache.scm
index 9063acb..01db7ae 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,7 +29,7 @@
 (define-public ccache
   (package
     (name "ccache")
-    (version "3.2.2")
+    (version "3.2.5")
     (source
      (origin
       (method url-fetch)
                           version ".tar.xz"))
       (sha256
        (base32
-        "1jm0qb3h5sypllaiyj81zp6m009vm50hzjnx994ril94kxlrj3ag"))))
+        "11db1g109g0g5si0s50yd99ja5f8j4asxb081clvx78r9d9i2w0i"))))
     (build-system gnu-build-system)
-    (native-inputs `(("perl" ,perl)))   ;for test.sh
+    (native-inputs `(("perl" ,perl)     ;for test.sh
+                     ("which" ,(@ (gnu packages base) which))))
     (inputs `(("zlib" ,zlib)))
     (arguments
      '(#:phases (alist-cons-before
                  'check 'setup-tests
                  (lambda _
                    (substitute* '("test/test_hashutil.c" "test.sh")
-                     (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                   (setenv "SHELL" (which "sh"))
+                     (("#!/bin/sh") (string-append "#!" (which "sh")))
+                     (("which") (which "which")))
                    #t)
                  %standard-phases)))
     (home-page "https://ccache.samba.org/")