gnu: Do not #:select from (gnu packages …) modules.
[jackhill/guix/guix.git] / gnu / packages / gstreamer.scm
index 9b113fd..1235b31 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gstreamer)
-  #:use-module ((guix licenses) #:select (lgpl2.0+ bsd-2 bsd-3))
+  #:use-module ((guix licenses) #:select (lgpl2.0+ bsd-2 bsd-3 gpl2+))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages audio)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages mp3)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages yasm)
   #:use-module (gnu packages xml))
 
 (define-public orc
   (package
     (name "orc")
-    (version "0.4.23")
+    (version "0.4.24")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://gstreamer.freedesktop.org/data/src/"
                                   "orc/orc-" version ".tar.xz"))
               (sha256
                (base32
-                "1ryz1gfgrxcj806cakcblxf0bcwq8p2mw8k86fs3f5wlwayawzkn"))))
+                "16ykgdrgxr6pfpy931p979cs68klvwmk3ii1k0a00wr4nn9x931k"))))
     (build-system gnu-build-system)
     (arguments `(#:phases
                  (alist-cons-before
@@ -78,17 +83,23 @@ arrays of data.")
 (define-public gstreamer
   (package
     (name "gstreamer")
-    (version "1.4.5")
+    (version "1.6.1")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-                          version ".tar.xz"))
+      (uri (string-append
+            "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+            version ".tar.xz"))
       (sha256
        (base32
-        "1bmhbhak6i5wmmb6w86jyyv8lax4gdq983la4lk4a0krz6kim020"))))
+        "172w1bpnkn6mm1wi37n03apdbb6cdkykhzjf1vfxchcd7hhkyflp"))))
     (build-system gnu-build-system)
-    (arguments '(#:make-flags '("CC=gcc"))) ; for g-ir-scanner.
+    (outputs '("out" "doc"))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))))
     (propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
     (native-inputs
      `(("bison" ,bison)
@@ -98,13 +109,17 @@ arrays of data.")
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "GST_PLUGIN_SYSTEM_PATH")
+            (files '("lib/gstreamer-1.0")))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis "Multimedia library")
     (description
      "GStreamer is a library for constructing graphs of media-handling
 components.  The applications it supports range from simple Ogg/Vorbis
-playback, audio/video streaming to complex audio (mixing) and video
- (non-linear editing) processing.
+playback, audio/video streaming to complex audio mixing and video
+non-linear editing.
 
 Applications can take advantage of advances in codec and filter technology
 transparently.  Developers can add new codecs and filters by writing a
@@ -113,45 +128,22 @@ simple plugin with a clean, generic interface.
 This package provides the core library and elements.")
     (license lgpl2.0+)))
 
-(define-public gstreamer-0.10
-  (package (inherit gstreamer)
-    (version "0.10.36")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
-      (patches
-        (list (search-patch "gstreamer-0.10-bison3.patch")
-              (search-patch "gstreamer-0.10-silly-test.patch")))))
-    (propagated-inputs
-     `(("libxml2" ,libxml2)))
-    (inputs `(("glib" ,glib)))
-    (native-inputs
-     `(("bison" ,bison)
-       ("flex" ,flex)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("glib" ,glib "bin")
-       ("python" ,python-2)))))
-
-
 (define-public gst-plugins-base
   (package
     (name "gst-plugins-base")
-    (version "1.4.5")
+    (version "1.6.1")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
-                          version ".tar.xz"))
+      (uri (string-append "http://gstreamer.freedesktop.org/src/" name "/"
+                          name "-" version ".tar.xz"))
       (sha256
        (base32
-        "07ampnfa6p41s0lhia62l9h8bdx3c7vxvdz93pbx64m3wycq3gbp"))))
+        "18sbyjcp281zb3bsqji3pglsdsxi0s6ai7rx90sx8cpflkxdqcwm"))))
     (build-system gnu-build-system)
+    (outputs '("out" "doc"))
+    (propagated-inputs
+     `(("gstreamer" ,gstreamer))) ; required by gstreamer-plugins-base-1.0.pc
     (inputs
      `(("cdparanoia" ,cdparanoia)
        ("orc" ,orc)
@@ -163,16 +155,21 @@ This package provides the core library and elements.")
        ("zlib" ,zlib)
        ("libXext" ,libxext)
        ("libxv" ,libxv)
-       ("alsa-lib" ,alsa-lib)
-       ("gstreamer" ,gstreamer)))
+       ("alsa-lib" ,alsa-lib)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("glib" ,glib "bin")
+        ("gobject-introspection" ,gobject-introspection)
         ("python-wrapper" ,python-wrapper)))
     (arguments
-     '(#:phases
+     `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
+       #:configure-flags
+       (list (string-append "--with-html-dir="
+                            (assoc-ref %outputs "doc")
+                            "/share/gtk-doc/html"))
+       #:phases
        (alist-cons-before
-        'configure 'patch-test-pb-utils
+        'configure 'patch
         (lambda _
           (substitute* "tests/check/libs/pbutils.c"
             (("/bin/sh") (which "sh"))))
@@ -188,42 +185,55 @@ for the GStreamer multimedia library.")
 (define-public gst-plugins-good
   (package
     (name "gst-plugins-good")
-    (version "1.4.5")
+    (version "1.6.1")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append 
+      (uri (string-append
             "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-"
             version ".tar.xz"))
       (sha256
        (base32
-        "0hg6qzdpib9nwn3hdxv0d4rvivi1c4bmxsq2a9hqmamwyzrvbcbr"))))
+        "0darc3058kbnql3mnlpizl0sq0hhli7vkm0rpqb7nywz14abim46"))))
     (build-system gnu-build-system)
     (inputs
-     `(("glib" ,glib)
+     `(("aalib" ,aalib)
        ("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf)
        ("flac" ,flac)
-       ("speex" ,speex)
-       ("libogg" ,libogg) ;; should be a propagated input of the above
-       ("libx11" ,libx11)
-       ("zlib" ,zlib)
-       ("libpng" ,libpng)
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("jack" ,jack-1)
+       ("libavc1394" ,libavc1394)
+       ("libcaca" ,libcaca)
+       ("libdv" ,libdv)
+       ("libiec61883" ,libiec61883)
        ("libjpeg" ,libjpeg)
-       ("libXext" ,libxext)
-       ("libxv" ,libxv)
+       ("libpng" ,libpng)
+       ("libshout" ,libshout)
+       ("libsoup" ,libsoup)
+       ("libvpx" ,libvpx)
+       ("orc" ,orc)
        ("pulseaudio" ,pulseaudio)
-       ("gstreamer" ,gstreamer)))
+       ("speex" ,speex)
+       ("taglib" ,taglib)
+       ("wavpack" ,wavpack)))
     (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("glib" ,glib "bin")
-        ("gst-plugins-base" ,gst-plugins-base)
-        ("python-wrapper" ,python-wrapper)))
-   (arguments
-    `(#:configure-flags (list "--disable-osx_audio" 
-                              "--disable-osx_video"
-                              "--disable-directsound"
-                              "--disable-waveform")))
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)
+       ("python-wrapper" ,python-wrapper)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after
+          'unpack 'disable-failing-rtprtx-tests
+          (lambda _
+            ;; Disable rtprtx tests that frequently fail.
+            ;; XXX FIXME: Try removing this for version > 1.6.1.
+            (substitute* "tests/check/elements/rtprtx.c"
+              (("tcase_add_test \\(tc_chain,\
+ (test_rtxsender_max_size_packets|test_rtxreceive_data_reconstruction)\\);" all)
+               (string-append "/* " all " */")))
+            #t)))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis
      "Plugins for the GStreamer multimedia library")
@@ -232,22 +242,77 @@ GStreamer multimedia library.  This set contains those plug-ins which the
 developers consider to have good quality code and correct functionality.")
     (license lgpl2.0+)))
 
-(define-public gst-plugins-base-0.10
-  (package (inherit gst-plugins-base)
-    (version "0.10.36")
+(define-public gst-plugins-ugly
+  (package
+    (name "gst-plugins-ugly")
+    (version "1.6.1")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append 
-            "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
-            version ".tar.xz"))
-      (sha256
-       (base32
-        "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
+       (method url-fetch)
+       (uri (string-append "http://gstreamer.freedesktop.org/src/"
+                           name "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0mvasl1pwq70w2kmrkcrg77kggl5q7jqybi7fkvy3vr28c7gkhqc"))))
+    (build-system gnu-build-system)
     (inputs
-     `(("glib" ,glib)
-       ("gstreamer" ,gstreamer-0.10)))
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("liba52" ,liba52)
+       ("libmad" ,libmad)
+       ("lame" ,lame)
+       ("libcdio" ,libcdio)
+       ("twolame" ,twolame)
+       ("libmpeg2" ,libmpeg2)
+       ("libdvdread" ,libdvdread)
+       ("libx264" ,libx264)
+       ;; TODO:
+       ;; * opencore-amr (for the AMR-NB decoder and encoder and the
+       ;;   AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>
+       ("orc" ,orc)))
     (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("glib" ,glib "bin")
-        ("python" ,python-2)))))
+     `(("glib:bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)
+       ("python-wrapper" ,python-wrapper)))
+    (home-page "http://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer plugins from the \"ugly\" set")
+    (description "GStreamer Ugly Plug-ins.  This set contains those plug-ins
+which the developers consider to have good quality code but that might pose
+distribution problems in some jurisdictions, e.g. due to patent threats.")
+    (license lgpl2.0+)))
+
+(define-public gst-libav
+  (package
+    (name "gst-libav")
+    (version "1.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://gstreamer.freedesktop.org/src/" name "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1a9pc7zp5rg0cvpx8gqkr21w73i6p9xa505a34day9f8p3lfim94"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--with-system-libav")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-/bin/sh
+                     (lambda _
+                       (substitute* "gst-libs/ext/libav/configure"
+                         (("#! /bin/sh")
+                          (string-append "#! "(which "sh")))))))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("ffmpeg" ,ffmpeg)
+       ("orc" ,orc)
+       ("zlib" ,zlib)))
+    (home-page "http://gstreamer.freedesktop.org/")
+    (synopsis "Plugins for the GStreamer multimedia library")
+    (description
+     "This GStreamer plugin supports a large number of audio and video
+compression formats through the use of the libav library.")
+    (license gpl2+)))