gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / perl-web.scm
index 75637e6..7bc406c 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
   #:use-module (guix packages)
+  #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-check)
   #:use-module (guix download)
-  #:use-module (guix build-system perl))
+  #:use-module (guix build-system perl)
+  #:use-module (gnu packages web))
 
 (define-public perl-mojolicious
   (package
     (name "perl-mojolicious")
-    (version "7.29")
+    (version "7.59")
     (source
      (origin
        (method url-fetch)
@@ -34,9 +38,9 @@
                            version ".tar.gz"))
        (sha256
         (base32
-         "1kmyb9axqbklyvr3l4d6mxnb0r97s9hzn7jpzksgckklp1ic8sqh"))))
+         "11whfrbafj191ahbhlhadws0vkg9kmvqswzkvswgwajhr1x678rh"))))
     (build-system perl-build-system)
-    (home-page "http://mojolicious.org/")
+    (home-page "https://mojolicious.org/")
     (synopsis "Real-time web framework")
     (description "Back in the early days of the web, many people learned Perl
 because of a wonderful Perl library called @code{CGI}.  It was simple enough
@@ -45,3 +49,79 @@ keep you going, learning by doing was much fun.  While most of the techniques
 used are outdated now, the idea behind it is not.  Mojolicious is a new
 endeavor to implement this idea using modern technologies.")
     (license license:artistic2.0)))
+
+(define-public perl-uri-db
+  (package
+    (name "perl-uri-db")
+    (version "0.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/D/DW/DWHEELER/URI-db-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0n56xxlw7c39pfar0dxckr9mbmp6yrzk53ic0cb24raiykm9v6f4"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (propagated-inputs
+     `(("perl-uri" ,perl-uri)
+       ("perl-uri-nested" ,perl-uri-nested)))
+    (home-page "https://metacpan.org/release/URI-db")
+    (synopsis "Handle database URIs")
+    (description
+     "This module defines a format for database URIs, and provides a @{URI}
+class to handle these.")
+    (license license:perl-license)))
+
+(define-public perl-uri-escape
+  (package
+    (name "perl-uri-escape")
+    (version "1.76")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/URI-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0gj1aj18k43kmzc3y1zhj5giinf8rksacf757r475xfna0fqxjdj"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-needs" ,perl-test-needs)))
+    (home-page "https://github.com/libwww-perl/URI")
+    (synopsis "Percent-encode and percent-decode unsafe characters")
+    (description "This module provides functions to percent-encode and
+percent-decode URI strings as defined by RFC 3986.  Percent-encoding URI's is
+informally called URI escaping.  This is the terminology used by this module,
+which predates the formalization of the terms by the RFC by several years.")
+    (license license:perl-license)))
+
+(define-public perl-uri-nested
+  (package
+    (name "perl-uri-nested")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/D/DW/DWHEELER/URI-Nested-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1bzg6f11m8wfnmycflvp858rs99xknsx8hkip0xcdfjzlqwi75z1"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (propagated-inputs
+     `(("perl-uri" ,perl-uri)))
+    (home-page "https://metacpan.org/release/URI-Nested")
+    (synopsis "Nested URIs")
+    (description
+     "@code{URI::Nested} provides support for nested URIs, where the scheme is
+a prefix, and the remainder of the URI is another URI.")
+    (license license:perl-license)))