gnu: cmake: Update to 3.7.2.
[jackhill/guix/guix.git] / gnu / packages / cmake.scm
index 1fb9241..3ffa7d4 100644 (file)
@@ -3,6 +3,8 @@
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages file)
+  #:use-module (gnu packages libevent)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages xml))
 
 (define-public cmake
   (package
     (name "cmake")
-    (version "3.1.3")
+    (version "3.7.2")
     (source (origin
              (method url-fetch)
-             (uri (string-append
-                   "http://www.cmake.org/files/v"
-                   (version-major+minor version)
-                   "/cmake-" version ".tar.gz"))
+             (uri (string-append "https://www.cmake.org/files/v"
+                                 (version-major+minor version)
+                                 "/cmake-" version ".tar.gz"))
              (sha256
-              (base32 "1l662p9lscbzx9s85y86cynb9fn1rb2alqg4584wqq9gibxd7x25"))
-             (patches (list (search-patch "cmake-fix-tests.patch")))))
+              (base32
+               "1q6a60695prpzzsmczm2xrgxdb61fyjznb04dr6yls6iwv24c4nw"))
+             (patches (search-patches "cmake-fix-tests.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
-       #:phases (alist-cons-before
-                 'configure 'patch-bin-sh
-                 (lambda _
-                   ;; Replace "/bin/sh" by the right path in... a lot of
-                   ;; files.
-                   (substitute*
-                       '("Modules/CompilerId/Xcode-3.pbxproj.in"
-                         "Modules/CompilerId/Xcode-1.pbxproj.in"
-                         "Modules/CompilerId/Xcode-2.pbxproj.in"
-                         "Modules/CPack.RuntimeScript.in"
-                         "Source/cmakexbuild.cxx"
-                         "Source/cmGlobalXCodeGenerator.cxx"
-                         "Source/CTest/cmCTestBatchTestHandler.cxx"
-                         "Source/cmLocalUnixMakefileGenerator3.cxx"
-                         "Source/cmExecProgramCommand.cxx"
-                         "Utilities/cmbzip2/Makefile-libbz2_so"
-                         "Utilities/Release/release_cmake.cmake"
-                         "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
-                         "Tests/CMakeLists.txt")
-                     (("/bin/sh") (which "sh"))))
-                 (alist-cons-before
-                  'configure 'set-paths
-                  (lambda _
-                    ;; Help cmake's bootstrap process to find system libraries
-                    (begin
-                      (setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
-                      (setenv "CMAKE_INCLUDE_PATH" (getenv "CPATH"))))
-                  (alist-replace
-                   'configure
-                   (lambda* (#:key outputs #:allow-other-keys)
-                     (let ((out (assoc-ref outputs "out")))
-                       (zero? (system*
-                               "./configure"
-                               (string-append "--prefix=" out)
-                               "--system-libs"
-                               ;; By default, the man pages and other docs land
-                               ;; in PREFIX/man and PREFIX/doc, but we want them
-                               ;; in share/{man,doc}.  Note that unlike
-                               ;; autoconf-generated configure scripts, cmake's
-                               ;; configure prepends "PREFIX/" to what we pass
-                               ;; to --mandir and --docdir.
-                               "--mandir=share/man"
-                               ,(string-append
-                                 "--docdir=share/doc/cmake-"
-                                 (version-major+minor version))))))
-                   %standard-phases)))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-bin-sh
+           (lambda _
+           ;; Replace "/bin/sh" by the right path in... a lot of
+           ;; files.
+           (substitute*
+               '("Modules/CompilerId/Xcode-3.pbxproj.in"
+                 "Modules/CompilerId/Xcode-1.pbxproj.in"
+                 "Modules/CompilerId/Xcode-2.pbxproj.in"
+                 "Modules/CPack.RuntimeScript.in"
+                 "Source/cmakexbuild.cxx"
+                 "Source/cmGlobalXCodeGenerator.cxx"
+                 "Source/CTest/cmCTestBatchTestHandler.cxx"
+                 "Source/cmLocalUnixMakefileGenerator3.cxx"
+                 "Source/cmExecProgramCommand.cxx"
+                 "Utilities/cmbzip2/Makefile-libbz2_so"
+                 "Utilities/Release/release_cmake.cmake"
+                 "Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
+                 "Tests/CMakeLists.txt"
+                 "Tests/RunCMake/File_Generate/RunCMakeTest.cmake")
+               (("/bin/sh") (which "sh")))
+           #t))
+         (add-before 'configure 'set-paths
+           (lambda _
+             ;; Help cmake's bootstrap process to find system libraries
+             (begin
+               (setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
+               (setenv "CMAKE_INCLUDE_PATH" (getenv "C_INCLUDE_PATH"))
+               ;; Get verbose output from failed tests
+               (setenv "CTEST_OUTPUT_ON_FAILURE" "TRUE")
+               #t)))
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (zero? (system*
+                       "./configure"
+                       (string-append "--prefix=" out)
+                       "--system-libs"
+                       "--no-system-jsoncpp" ; not packaged yet
+                       ;; By default, the man pages and other docs land
+                       ;; in PREFIX/man and PREFIX/doc, but we want them
+                       ;; in share/{man,doc}.  Note that unlike
+                       ;; autoconf-generated configure scripts, cmake's
+                       ;; configure prepends "PREFIX/" to what we pass
+                       ;; to --mandir and --docdir.
+                       "--mandir=share/man"
+                       ,(string-append
+                         "--docdir=share/doc/cmake-"
+                         (version-major+minor version))))))))))
     (inputs
      `(("file"       ,file)
        ("curl"       ,curl)
        ("zlib"       ,zlib)
        ("expat"      ,expat)
        ("bzip2"      ,bzip2)
+       ("ncurses"    ,ncurses) ; required for ccmake
+       ("libuv"      ,libuv)
        ("libarchive" ,libarchive)))
     (native-search-paths
      (list (search-path-specification
              (variable "CMAKE_PREFIX_PATH")
              (files '("")))))
-    (home-page "http://www.cmake.org/")
+    (home-page "https://www.cmake.org/")
     (synopsis "Cross-platform build system")
     (description
      "CMake is a family of tools designed to build, test and package software.