gnu: ibus-anthy: Update to 1.5.9.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
index 150e1e0..571770b 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,7 +29,7 @@
 (define-public nano
   (package
     (name "nano")
-    (version "2.4.0")
+    (version "2.7.5")
     (source
      (origin
       (method url-fetch)
                           version ".tar.gz"))
       (sha256
        (base32
-        "1gbm9bcv4k55y01r5q8a8a9s3yrrgq3z5jxxiij3wl404r8gnxjh"))))
+        "01yrh66rph0vn9q9r2d2jji5yzaakxrj75j9fsm0g41m8qpy4sr2"))))
     (build-system gnu-build-system)
     (inputs
-     `(("gettext" ,gnu-gettext)
+     `(("gettext" ,gettext-minimal)
        ("ncurses" ,ncurses)))
-    (home-page "http://www.nano-editor.org/")
+    (home-page "https://www.nano-editor.org/")
     (synopsis "Small, user-friendly console text editor")
     (description
-     "GNU Nano is a small and simple text editor.  In addition to basic
-editing, it supports interactive search and replace, go to line and column
-number, auto-indentation and more.")
+     "GNU nano is a small and simple text editor for use in a terminal.  Besides
+basic editing, it supports: undo/redo, syntax highlighting, spell checking,
+justifying, auto-indentation, bracket matching, interactive search-and-replace
+(with regular expressions), and the editing of multiple files.")
     (license gpl3+))) ; some files are under GPLv2+