gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / libcanberra.scm
index 121ba11..e263ba2 100644 (file)
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
-;;; Copyright © 2017, 2018 ng0 <ng0@n0.is>
+;;; Copyright © 2017, 2018 Nikita <nikita@n0.is>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -69,7 +69,8 @@
       ;; his pleasure.
       (patch-flags '("-p0"))
       (patches
-       (search-patches "libcanberra-sound-theme-freedesktop.patch"))))
+       (search-patches "libcanberra-sound-theme-freedesktop.patch"
+                       "libcanberra-wayland-crash.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)
@@ -104,7 +105,7 @@ null) and is designed to be portable.")
     (license lgpl2.1+)))
 
 (define-public libcanberra/gtk+-2
-  (package (inherit libcanberra)
+  (package/inherit libcanberra
     (name "libcanberra-gtk2")
     (inputs `(,@(alist-delete "gtk+" (package-inputs libcanberra))
               ("gtk+" ,gtk+-2)))))