gnu: Use 'modify-phases' syntax.
[jackhill/guix/guix.git] / gnu / packages / gprolog.scm
index f82a1a1..b27b080 100644 (file)
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gprolog)
+  #:use-module (guix download)
   #:use-module (guix licenses)
   #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (srfi srfi-1))
 
 (define-public gprolog
   (package
         "13miyas47bmijmadm68cbvb21n4s156gjafz7kfx9brk9djfkh0q"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (alist-cons-before
-                 'configure 'change-dir-n-fix-shells
-                 (lambda _
-                   (chdir "src")
-                   (substitute* "configure"
-                     (("-/bin/sh")  (string-append "-"  (which "sh")))
-                     (("= /bin/sh") (string-append "= " (which "sh")))))
-                 %standard-phases)))
+     `(#:configure-flags
+       (list (string-append
+              "--with-install-dir=" %output "/share/gprolog"))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'change-dir-n-fix-shells
+           (lambda _
+             (chdir "src")
+             (substitute* "configure"
+               (("-/bin/sh")  (string-append "-"  (which "sh")))
+               (("= /bin/sh") (string-append "= " (which "sh"))))
+             #t)))))
     (home-page "https://www.gnu.org/software/gprolog/")
     (synopsis "Prolog compiler")
     (description
-     "GNU Prolog is a free Prolog compiler with constraint solving over
-finite domains developed by Daniel Diaz.
-
-GNU Prolog accepts Prolog+constraint programs and produces native
-binaries (like gcc does from a C source).  The obtained executable is
-then stand-alone.  The size of this executable can be quite small since
-GNU Prolog can avoid to link the code of most unused built-in
-predicates.  The performances of GNU Prolog are very
-encouraging (comparable to commercial systems).
-
-Beside the native-code compilation, GNU Prolog offers a classical
-interactive interpreter (top-level) with a debugger.
-
-The Prolog part conforms to the ISO standard for Prolog with many
-extensions very useful in practice (e.g., global variables, OS
-interface, sockets).
+     "GNU Prolog is a standards-compliant Prolog compiler with constraint
+solving over finite domains.  It accepts Prolog+ constraint programs and
+produces a compiled, native binary which can function in a stand-alone
+manner.  It also features an interactive interpreter.")
+    (license (list gpl2+ lgpl3+))
 
-GNU Prolog also includes an efficient constraint solver over finite domains.
-This opens contraint logic programming to the user combining the power of
-constraint programming to the declarativity of logic programming.")
-    (license (list gpl2+ lgpl3+))))
+    ;; See 'configure' for the list of supported architectures.
+    (supported-systems (fold delete
+                             %supported-systems
+                             '("armhf-linux" "mips64el-linux")))))