gnu: Fix common unquote typos.
[jackhill/guix/guix.git] / gnu / packages / ratpoison.scm
index 30e6c22..1932187 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module (gnu packages)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages fontutils))
 
+(define ratpoison.desktop
+  (origin
+    (method url-fetch)
+    (uri (string-append "https://sources.gentoo.org/cgi-bin/viewvc.cgi/"
+                        "gentoo-x86/x11-wm/ratpoison/files/ratpoison.desktop"
+                        "?revision=1.1"))
+    (file-name "ratpoison.desktop")
+    (sha256
+     (base32
+      "1rh3f4c3rhn6q2hmkraam0831xqcqyj3qkqf019ahaxsxaan3553"))))
+
 (define-public ratpoison
   (package
     (name "ratpoison")
-    (version "1.4.6")
-    (source (origin
-             (method url-fetch)
+    (version "1.4.9")
+    (source
+     (origin (method url-fetch)
              (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0v4mh8d3vsh5xbbycfdl3g8zfygi1rkslh1x7k5hi1d05bfq3cdr"))))
+               "1wfir1gvh5h7izgvx2kd1pr2k7wlncd33zq7qi9s9k2y0aza93yr"))
+             (patches (search-patches "ratpoison-shell.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-xsession
+                    (lambda* (#:key inputs outputs #:allow-other-keys)
+                      (let ((rpd "ratpoison.desktop")
+                            (dst (string-append (assoc-ref outputs "out")
+                                                "/share/xsessions/")))
+                        (mkdir-p dst)
+                        (copy-file (assoc-ref inputs rpd)
+                                   (string-append dst rpd))))))))
     (inputs
-     `(("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("libXi" ,libxi)
-       ("readline" ,readline)
-       ("xextproto" ,xextproto)
-       ("libXtst" ,libxtst)
-       ("freetype" ,freetype)
+     `(("inputproto" ,inputproto)
        ("fontconfig" ,fontconfig)
+       ("freetype" ,freetype)
        ("libXft" ,libxft)
+       ("libXi" ,libxi)
+       ("libxrandr" ,libxrandr)
        ("libXpm" ,libxpm)
        ("libXt" ,libxt)
-       ("inputproto" ,inputproto)
-       ("libX11" ,libx11)))
-    (home-page "http://www.nongnu.org/ratpoison/")
-    (synopsis "A simple mouse-free tiling window manager")
+       ("libXtst" ,libxtst)
+       ("libX11" ,libx11)
+       ("readline" ,readline)
+       ("xextproto" ,xextproto)))
+    (native-inputs
+     `(("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("ratpoison.desktop" ,ratpoison.desktop)))
+    (home-page "https://www.nongnu.org/ratpoison/")
+    (synopsis "Simple mouse-free tiling window manager")
     (description
      "Ratpoison is a simple window manager with no fat library
 dependencies, no fancy graphics, no window decorations, and no