gnu: datefudge: Update to 1.23.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
index e76545a..5b3f850 100644 (file)
@@ -39,7 +39,6 @@
 (define-public gd
   (package
     (name "gd")
-    (replacement gd/fixed)
     ;; Note: With libgd.org now pointing to github.com, genuine old
     ;; tarballs are no longer available.  Notably, versions 2.0.x are
     ;; missing.
@@ -55,6 +54,8 @@
 
              (patches (search-patches "gd-CVE-2018-5711.patch"
                                       "gd-CVE-2018-1000222.patch"
+                                      "gd-CVE-2019-6977.patch"
+                                      "gd-CVE-2019-6978.patch"
                                       "gd-fix-tests-on-i686.patch"
                                       "gd-freetype-test-failure.patch"))))
     (build-system gnu-build-system)
@@ -95,16 +96,6 @@ most common applications of GD involve website development.")
                            "See COPYING file in the distribution."))
     (properties '((cpe-name . "libgd")))))
 
-(define-public gd/fixed
-  (hidden-package
-    (package
-      (inherit gd)
-      (source (origin
-                (inherit (package-source gd))
-                (patches (append (origin-patches (package-source gd))
-                                 (search-patches "gd-CVE-2019-6977.patch"
-                                                 "gd-CVE-2019-6978.patch"))))))))
-
 (define-public perl-gd
   (package
     (name "perl-gd")
@@ -138,15 +129,14 @@ you can create PNG images on the fly or modify existing files.")
 (define-public perl-gd-securityimage
   (package
     (name "perl-gd-securityimage")
-    (version "1.73")
+    (version "1.75")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://cpan/authors/id/B/BU/BURAK/"
                            "GD-SecurityImage-" version ".tar.gz"))
        (sha256
-        (base32
-         "1kaxs67rfd4w46lxgcg3pa05a596l0h1k8n4zk2gwrrar4022wpx"))))
+        (base32 "19lf1kzdavrkkx3f900jnpynr55d5kjd2sdmwpfir5dsmkcj9pix"))))
     (build-system perl-build-system)
     (arguments
      '(#:phases