gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / dictionaries.scm
index ac020b2..062c29b 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix build-system gnu)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages curl)
+  #:use-module (gnu packages emacs)
+  #:use-module (gnu packages fribidi)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages texinfo)
-  #:use-module (gnu packages compression))
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages tcl))
+
 
 (define-public vera
   (package
     (native-inputs `(("texinfo" ,texinfo)
                      ("tar" ,tar)
                      ("gzip" ,gzip)))
-    (home-page "http://savannah.gnu.org/projects/vera/")
+    (home-page "https://savannah.gnu.org/projects/vera/")
     (synopsis "List of acronyms")
     (description
      "V.E.R.A. (Virtual Entity of Relevant Acronyms) is a list of computing
 acronyms distributed as an info document.")
     (license fdl1.3+)))
+
+(define-public gcide
+  (package
+    (name "gcide")
+    (version "0.51")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://gnu/gcide/gcide-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1wm0s51ygc6480dq8gwahzr35ls8jgpf34yiwl5yqcaa0i19fdv7"))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:builder (begin
+                   (use-modules (guix build utils))
+                   (let* ((src     (assoc-ref %build-inputs "source"))
+                          (tar     (assoc-ref %build-inputs "tar"))
+                          (xz      (assoc-ref %build-inputs "xz"))
+                          (out     (assoc-ref %outputs "out"))
+                          (datadir (string-append out "/share/gcide")))
+                     (set-path-environment-variable "PATH" '("bin")
+                                                    (list tar xz))
+                     (mkdir-p datadir)
+                     (zero? (system* "tar" "-C" datadir
+                                     "--strip-components=1"
+                                     "-xvf" src))))
+       #:modules ((guix build utils))))
+    (native-inputs
+     `(("tar" ,tar)
+       ("xz" ,xz)))
+    (synopsis "GNU Collaborative International Dictionary of English")
+    (description
+     "GCIDE is a free dictionary based on a combination of sources.  It can
+be used via the GNU Dico program or accessed online at
+http://gcide.gnu.org.ua/")
+    (home-page "http://gcide.gnu.org.ua/")
+    (license gpl3+)))
+
+(define-public diction
+  ;; Not quite a dictionary, not quite a spell checker either…
+  (package
+    (name "diction")
+    (version "1.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/diction/diction-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1xi4l1x1vvzmzmbhpx0ghmfnwwrhabjwizrpyylmy3fzinzz3him"))))
+    (build-system gnu-build-system)
+    (synopsis "Identifies wordy and commonly misused phrases")
+    (description
+     "A package providing two classic Unix commands, style and diction.
+Diction is used to identify wordy and commonly misused phrases in a
+body of text.  Style instead analyzes surface aspects of a written
+work, such as sentence length and other readability measures.")
+    (home-page "https://www.gnu.org/software/diction/")
+    (license gpl3+)))
+
+(define-public ding
+  (package
+    (name "ding")
+    (version "1.8")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://ftp.tu-chemnitz.de/pub/Local/urz/" name
+                                  "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "00z97ndwmzsgig9q6y98y8nbxy76pyi9qyj5qfpbbck24gakpz5l"))))
+    (build-system gnu-build-system)
+    (inputs `(("tk" ,tk)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (delete 'check)
+         (replace
+             'install
+           (lambda _
+             (let ((bindir (string-append
+                            (assoc-ref %outputs "out") "/bin"))
+                   (wish (string-append
+                          (assoc-ref %build-inputs "tk")
+                          "/bin/wish8.6"))
+                   (sharedir (string-append
+                              (assoc-ref %outputs "out")
+                              "/share/applications"))
+                   (libdir (string-append
+                            (assoc-ref %outputs "out") "/lib")))
+               (mkdir-p bindir)
+               (mkdir-p libdir)
+               (mkdir-p sharedir)
+
+               (substitute* "ding.desktop"
+                 (("Exec=/usr/bin/ding")
+                  (string-append "Exec=" bindir "/ding")))
+               (with-fluids ((%default-port-encoding "ISO-8859-1"))
+                 (substitute* "ding" (("exec wish") (string-append "exec " wish))))
+               (substitute* "install.sh"
+                 (("/bin/cp") "cp")
+                 (("/bin/mv") "mv")
+                 (("NEEDPROG=\"wish\"")
+                  (string-append "NEEDPROG=\"" wish "\""))
+                 (("DEFBINDIR=\"/usr/local/bin\"")
+                  (string-append "DEFBINDIR=\"" bindir "\""))
+                 (("DEFLIBDIR=\"/usr/local/lib\"")
+                  (string-append "DEFLIBDIR=\"" libdir "\"")))
+               (install-file "ding.desktop" sharedir)
+               (install-file "ding.png" sharedir)
+               (zero?
+                (system* "./install.sh"))))))))
+    (synopsis "Dictionary lookup program with a German-English dictionary")
+    (description "Ding is a dictionary lookup program for the X window system.
+It comes with a German-English dictionary with approximately 270,000 entries.")
+    (home-page  "http://www-user.tu-chemnitz.de/~fri/ding/")
+    (license gpl2+)))
+
+(define-public translate-shell
+  (package
+    (name "translate-shell")
+    (version "0.9.6.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://github.com/soimort/" name "/archive/v"
+                            version ".tar.gz"))
+        (sha256
+         (base32
+          "1fg6nf1plvgimc57fsdr9rcjbf7jvmk5jrlj5ya509vpdcdgvj2s"))
+        (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure phase
+         (add-after 'install 'emacs-install
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out   (assoc-ref outputs "out"))
+                    (dest  (string-append out "/share/emacs/site-lisp"))
+                    (emacs (string-append (assoc-ref inputs "emacs") "/bin/emacs")))
+               (install-file "google-translate-mode.el" dest)
+               (emacs-generate-autoloads ,name dest)))))
+       #:make-flags (list (string-append "PREFIX=" %output))
+       #:imported-modules (,@%gnu-build-system-modules (guix build emacs-utils))
+       #:modules ((guix build gnu-build-system)
+                  (guix build emacs-utils)
+                  (guix build utils))
+       #:test-target "test"))
+    (propagated-inputs
+     `(("curl" ,curl)
+       ("fribidi" ,fribidi)
+       ("rlwrap" ,rlwrap)))
+    (native-inputs
+     `(("emacs" ,emacs-minimal)
+       ("util-linux" ,util-linux))) ; hexdump, for the test
+    (home-page "https://www.soimort.org/translate-shell")
+    (synopsis "Translations from the command line")
+    (description
+     "Translate Shell (formerly Google Translate CLI) is a command-line
+translator powered by Google Translate (default), Bing Translator,
+Yandex.Translate and Apertium.  It gives you easy access to one of these
+translation engines from your terminal.")
+    (license public-domain)))