gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / adns.scm
index a6fbc1a..6e3af8b 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,7 +27,7 @@
 (define-public adns
   (package
     (name "adns")
-    (version "1.5.0")
+    (version "1.5.1")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "mirror://gnu/adns/adns-"
@@ -37,7 +37,7 @@
                           version ".tar.gz")))
               (sha256
                (base32
-                "0hg89b5n84zjhzvbzrpvhl0hbm4s6d1z2pzllfis64ai656ypibz"))))
+                "1ssfh94ck6kn98nf2yy6743srpgqgd167va5ja3bwx42igqjc42v"))))
     (build-system gnu-build-system)
     (arguments
      ;; Make sure the programs under bin/ fine libadns.so.
@@ -47,7 +47,7 @@
 
        ;; XXX: Tests expect real name resolution to work.
        #:tests? #f))
-    (home-page "http://www.gnu.org/software/adns/")
+    (home-page "https://www.gnu.org/software/adns/")
     (synopsis "Asynchronous DNS client library and utilities")
     (description
      "GNU adns is a C library that provides easy-to-use DNS resolution
@@ -59,19 +59,19 @@ scripts.")
 (define-public c-ares
   (package
     (name "c-ares")
-    (version "1.11.0")
+    (version "1.14.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://c-ares.haxx.se/download/" name "-" version
+                    "https://c-ares.haxx.se/download/" name "-" version
                     ".tar.gz"))
               (sha256
                (base32
-                "1z9y1f835dpi1ka2a2vzjygm3djdvr01036ml4l2js6r2xk2wqdk"))))
+                "0vnwmbvymw677k780kpb6sb8i3szdp89rzy8mz1fwg1657yw3ls5"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "http://c-ares.haxx.se/")
+    (home-page "https://c-ares.haxx.se/")
     (synopsis "C library for asynchronous DNS requests")
     (description
       "C-ares is a C library that performs DNS requests and name resolution
@@ -79,4 +79,4 @@ asynchronously.  It is intended for applications which need to perform DNS
 queries without blocking, or need to perform multiple DNS queries in parallel.
 The primary examples of such applications are servers which communicate with
 multiple clients and programs with graphical user interfaces.")
-    (license (x11-style "http://c-ares.haxx.se/license.html"))))
+    (license (x11-style "https://c-ares.haxx.se/license.html"))))