gnu: fontconfig: Add replacement with font-dejavu instead of gs-fonts.
[jackhill/guix/guix.git] / gnu / packages / antivirus.scm
index c3f1186..367ebe7 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public clamav
   (package
     (name "clamav")
-    (version "0.100.2")
+    (version "0.102.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.clamav.net/downloads/production/"
                                   "clamav-" version ".tar.gz"))
               (sha256
                (base32
-                "1mkd41sxbjkfjinpx5b9kb85q529gj2s3d0klysssqhysh64ybja"))
+                "14q6vi178ih60yz4ja33b6181va1dcj8fyscnmxfx2crav250c7d"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (for-each delete-file-recursively
-                            '("win32"              ;unnecessary
-                              "libclamav/c++/llvm" ;use system llvm
-                              "libclamunrar"))))   ;non-free license
+                            '("win32"                  ; unnecessary
+                              "libclamav/c++/llvm"     ; use system llvm
+                              "libclamav/tomsfastmath" ; use system tomsfastmath
+                              "libclamunrar"))         ; non-free license
+                  #t))
               (patches
                (search-patches "clamav-system-tomsfastmath.patch"
                                "clamav-config-llvm-libs.patch"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("bison" ,bison)
-       ("check" ,check)                 ;for tests
-       ("flex" ,flex)
-       ("pkg-config" ,pkg-config)
-       ;; The tomsfastmath patch touches configure.ac and Makefile.am
-       ("autoconf" ,autoconf)
+     `(("autoconf" ,autoconf)
        ("automake" ,automake)
-       ("libtool" ,libtool)))
+       ("check" ,check)                 ; for tests
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("bzip2" ,bzip2)
        ("libcurl" ,curl)
        ("libjson" ,json-c)
        ("libltdl" ,libltdl)
        ("libmspack" ,libmspack)
-       ("llvm" ,llvm-3.6)               ;requires <3.7, for JIT/verifier
+       ("llvm" ,llvm-3.6)               ; requires <3.7, for JIT/verifier
        ("ncurses" ,ncurses)
        ("openssl" ,libressl)
-       ("pcre" ,pcre "bin")             ;for pcre-config
-       ("sasl" ,cyrus-sasl)             ;for linking curl with libtool
+       ("pcre2" ,pcre2)
+       ("sasl" ,cyrus-sasl)             ; for linking curl with libtool
        ("tomsfastmath" ,tomsfastmath)
        ("xml" ,libxml2)
        ("zlib" ,zlib)))
@@ -99,7 +99,7 @@
                (with "xml")
                (with "openssl")
                (with "libjson")
-               (with "pcre")
+               (with "pcre2")
                (with "zlib")
                (with "libcurl")
                ;; For sanity, specifying --enable-* flags turns