gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / documentation.scm
index f533535..19c42b0 100644 (file)
@@ -123,39 +123,30 @@ markup) can be customized and extended by the user.")
 (define-public doxygen
   (package
     (name "doxygen")
-    (version "1.8.14")
+    (version "1.8.15")
+    (home-page "http://www.doxygen.nl/")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://ftp.stack.nl/pub/users/dimitri/"
-                                 name "-" version ".src.tar.gz"))
+             (uri (list (string-append home-page "files/doxygen-"
+                                       version ".src.tar.gz")
+                        (string-append "mirror://sourceforge/doxygen/rel-"
+                                       version "/doxygen-" version
+                                       ".src.tar.gz")))
              (sha256
               (base32
-               "0kcxymbam9jwiyjwyvwdjj0h74lbb6c467szsipzbxjyfl17wxfi"))
+               "0p94b4yb6bk2dxzs5kyl82xxgq2qakgbx5yy3ssbbadncb20x75x"))
              (patches (search-patches "doxygen-test.patch"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("bison" ,bison)
-       ("flex" ,flex-2.6.1) ; sefaults with 2.6.4
-       ("libxml2" ,libxml2) provides xmllint for the tests
-       ("python" ,python-2))) ; for creating the documentation
+       ("flex" ,flex)
+       ("libxml2" ,libxml2)             ;provides xmllint for the tests
+       ("python" ,python)))             ;for creating the documentation
     (inputs
-     `(("bash" ,bash-minimal)
-       ,@(if (string-prefix? "armhf-" (%current-system))
-             `(("gcc-ice-patch" ,@(search-patches "doxygen-gcc-ice.patch")))
-             '())))
+     `(("bash" ,bash-minimal)))
     (arguments
      `(#:test-target "tests"
        #:phases (modify-phases %standard-phases
-                  ;; Work around an ICE that shows up on native compiles for
-                  ;; armhf-linux.
-                  ,@(if (string-prefix? "armhf-" (%current-system))
-                        `((add-after 'unpack 'apply-gcc-patch
-                            (lambda* (#:key inputs #:allow-other-keys)
-                              (let ((patch (assoc-ref inputs "gcc-ice-patch")))
-                                (invoke "patch" "-p1" "--force"
-                                        "--input" patch)))))
-                        '())
-
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"
@@ -163,7 +154,6 @@ markup) can be customized and extended by the user.")
                                    (string-append
                                     (assoc-ref inputs "bash") "/bin/sh")))
                                 #t)))))
-    (home-page "http://www.stack.nl/~dimitri/doxygen/")
     (synopsis "Generate documentation from annotated sources")
     (description "Doxygen is the de facto standard tool for generating
 documentation from annotated C++ sources, but it also supports other popular