gnu: r-maldiquant: Move to (gnu packages cran).
[jackhill/guix/guix.git] / gnu / packages / javascript.scm
index 467a7d0..fbc7388 100644 (file)
@@ -188,7 +188,7 @@ Explorer 6-9, Safari 4.x (and iPhone 3.x), and Firefox 3.x.")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/douglascrockford/JSON-js.git")
+                      (url "https://github.com/douglascrockford/JSON-js")
                       (commit commit)))
                 (file-name (string-append name "-" version "-checkout"))
                 (sha256
@@ -303,7 +303,7 @@ HTML tables with minimal effort.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/requirejs/requirejs.git")
+                     (url "https://github.com/requirejs/requirejs")
                      (commit version)))
               (file-name (git-file-name name version))
               (sha256
@@ -393,6 +393,12 @@ means that these shams cause many ES5 methods to silently fail.")
            (lambda _
              (substitute* "src/FileSaver.js"
                (("export ") ""))
+             #t))
+         (add-after 'install 'install-unminified-version
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "src/FileSaver.js"
+                           (string-append (assoc-ref outputs "out")
+                                          "/share/javascript"))
              #t)))))
     (home-page
      "https://eligrey.com/blog/saving-generated-files-on-the-client-side/")
@@ -409,14 +415,14 @@ external server.")
 (define-public mujs
   (package
     (name "mujs")
-    (version "1.0.6")
+    (version "1.0.7")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://mujs.com/downloads/mujs-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1q9w2dcspfp580pzx7sw7x9gbn8j0ak6dvj75wd1ml3f3q3i43df"))))
+                "1ilhay15z4k7mlzs6g2d00snivin7vp72dfw5wwpmc0x70jr31l2"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases