gnu: Add emacs-highlight-sexp.
[jackhill/guix/guix.git] / gnu / packages / password-utils.scm
index 0a3b4b6..66d5f8c 100644 (file)
@@ -8,6 +8,7 @@
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
+  #:use-module (gnu packages aidc)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages glib)
@@ -106,7 +108,7 @@ algorithms AES or Twofish.")
     (version "0.1.1")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://files.dthompson.us/shroud/shroud-"
+              (uri (string-append "https://files.dthompson.us/shroud/shroud-"
                                   version ".tar.gz"))
               (sha256
                (base32
@@ -134,7 +136,7 @@ encrypted with a GnuPG key.  Secrets consist of an arbitrary number of
 key/value pairs, making Shroud suitable for more than just password storage.
 For copying and pasting secrets into web browsers and other graphical
 applications, there is xclip integration." )
-    (home-page "http://dthompson.us/pages/software/shroud.html")
+    (home-page "https://dthompson.us/projects/shroud.html")
     (license license:gpl3+)))
 
 (define-public yapet
@@ -282,7 +284,7 @@ any X11 window.")
 (define-public password-store
   (package
     (name "password-store")
-    (version "1.6.5")
+    (version "1.7")
     (source (origin
               (method url-fetch)
               (uri
@@ -290,7 +292,8 @@ any X11 window.")
                               name "-" version ".tar.xz"))
               (sha256
                (base32
-                "05bk3lrp5jwg0v338lvylp7glpliydzz4jf5pjr6k3kagrv3jyik"))))
+                "002mw7j0m33bw483rllzhcf41wp3ixka8yma6kqrfaj57jyw66hn"))
+              (patches (search-patches "password-store-gnupg-compat.patch"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -302,7 +305,7 @@ any X11 window.")
              (let ((out (assoc-ref outputs "out"))
                    (path (map (lambda (pkg)
                                 (string-append (assoc-ref inputs pkg) "/bin"))
-                              '("coreutils" "getopt" "git" "gnupg" "pwgen"
+                              '("coreutils" "getopt" "git" "gnupg" "qrencode"
                                 "sed" "tree" "which" "xclip"))))
                (wrap-program (string-append out "/bin/pass")
                  `("PATH" ":" prefix (,(string-join path ":"))))
@@ -325,7 +328,7 @@ any X11 window.")
      `(("getopt" ,util-linux)
        ("git" ,git)
        ("gnupg" ,gnupg)
-       ("pwgen" ,pwgen)
+       ("qrencode" ,qrencode)
        ("sed" ,sed)
        ("tree" ,tree)
        ("which" ,which)