change version string to SVN_XXX
[hcoop/zz_old/modwaklog.git] / debian / rules
index 1dd408c..afec231 100644 (file)
@@ -1,97 +1,77 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-
 
 CFLAGS = -Wall -g
-
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
 
-configure: configure-stamp
-configure-stamp:
+build-apache13:
        dh_testdir
-       # Add here commands to configure the package.
        chmod +x regen.sh
        ./regen.sh
-       ./configure --with-afs-libs=/usr/lib/afs --with-afs-headers=/usr/include/afs
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
+       make clean
+       ./configure \
+         --with-afs-libs=/usr/lib/afs \
+         --with-afs-headers=/usr/include/afs \
+         --with-apxs=/usr/bin/apxs
        $(MAKE)
-       #docbook-to-man debian/libapache-mod-waklog.sgml > libapache-mod-waklog.1
 
-       touch $@
-
-clean:
+build-apache20:
        dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
-       dh_clean  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
+       chmod +x regen.sh
+       ./regen.sh
+       make clean
+       ./configure \
+         --with-afs-libs=/usr/lib/afs \
+         --with-afs-headers=/usr/include/afs \
+         --with-apache-headers=/usr/include/apache2 \
+         --with-apxs=/usr/bin/apxs2
+       $(MAKE)
+       mv .libs/mod_waklog.so .; true
 
-install: build
+apache13: build-apache13
        dh_testdir
        dh_testroot
        dh_clean -k  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
        dh_installdirs
-
-       # Add here commands to install the package into debian/libapache-mod-waklog.
        mkdir -p debian/libapache-mod-waklog/usr/lib/apache/1.3/
        mkdir -p debian/libapache-mod-waklog/etc/apache/conf.d/
        cp mod_waklog.so debian/libapache-mod-waklog/usr/lib/apache/1.3/
        cp debian/waklog.load debian/libapache-mod-waklog/etc/apache/conf.d/waklog.conf
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+apache20: build-apache20
+       dh_testdir
+       dh_testroot
+       dh_clean -k  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
+       dh_installdirs
+       mkdir -p debian/libapache2-mod-waklog/usr/lib/apache2/modules/
+       mkdir -p debian/libapache2-mod-waklog/etc/apache2/mods-available
+       cp mod_waklog.so debian/libapache2-mod-waklog/usr/lib/apache2/modules/
+       cp debian/waklog.load debian/libapache2-mod-waklog/etc/apache2/mods-available
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -rf build-stamp .libs
+       -$(MAKE) clean
+       dh_clean  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
+
+binary-indep:
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch: apache13 apache20
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
-       dh_strip
+       #dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol