Include packages needed to build domtool
authorClinton Ebadi <clinton@unknownlamer.org>
Tue, 11 Dec 2012 03:54:30 +0000 (22:54 -0500)
committerClinton Ebadi <clinton@unknownlamer.org>
Tue, 11 Dec 2012 03:54:30 +0000 (22:54 -0500)
We have to, since deploying right now involves compiling on every
host.

preseed/preseed-test-0.cfg

index b8b7df0..f36ada7 100644 (file)
@@ -360,7 +360,8 @@ tasksel     tasksel/first   multiselect     SSH server, Standard system utilities
 #tasksel tasksel/desktop multiselect kde, xfce
 
 # Individual additional packages to install
-d-i pkgsel/include string build-essential less sudo vim emacs23-nox etckeeper changetrack openssh-server debsums logcheck bzip2 denyhosts rkhunter openafs-client ntp nscd krb5-user libpam-krb5 ssmtp libpam-afs-session openafs-krb5 ferm libnss-afs hcoop-nsswitch-config hcoop-admin-common-config
+d-i pkgsel/include string build-essential less sudo vim emacs23-nox etckeeper changetrack openssh-server debsums logcheck bzip2 denyhosts rkhunter openafs-client ntp nscd krb5-user libpam-krb5 kstart ssmtp libpam-afs-session openafs-krb5 ferm libnss-afs hcoop-nsswitch-config hcoop-admin-common-config hcoop-firewall-config hcoop-krb5-config hcoop-openssh-server-config \
+    mlton-compiler mlton-tools libssl-dev libpcre3-dev # domtool deps, a metapackage would be useful here
 # Whether to upgrade packages after debootstrap.
 # Allowed values: none, safe-upgrade, full-upgrade
 d-i pkgsel/upgrade select safe-upgrade