Imported Debian patch 0.7.1-1
[hcoop/zz_old/debian/suphp.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # These are used for cross-compiling and for saving the configure script
9 # from having to guess our platform (since we know it already)
10 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
11 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
12
13
14 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
15 CFLAGS += -g
16 endif
17 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
18 INSTALL_PROGRAM += -s
19 endif
20
21 patch:
22 dpatch apply-all
23
24 configure-apache2: patch
25 dh_testdir
26 CPPFLAGS="`pkg-config --cflags apr-1`" ./configure --prefix=/usr \
27 --sysconfdir=/etc/suphp \
28 --with-apxs=/usr/bin/apxs2 \
29 --with-apache-user=www-data \
30 --with-php=/usr/bin/php-cgi \
31 --sbindir=/usr/lib/suphp \
32 --with-setid-mode=owner \
33 --with-logfile=/var/log/suphp/suphp.log
34
35
36 build-apache2: configure-apache2
37 dh_testdir
38 $(MAKE)
39
40 build:
41
42 clean:
43 dh_testdir
44 dh_testroot
45 [ ! -f Makefile ] || $(MAKE) clean
46 rm -f config.log config.status src/config.h
47 rm -f libtool src/stamp-h
48 find . -name .libs | xargs rm -rf
49 find . -name .deps | xargs rm -rf
50 rm -f src/apache/mod_suphp.o src/apache/mod_suphp.lo src/apache/mod_suphp.la src/stamp-h1
51 find . -name Makefile | xargs rm -f
52 dh_clean
53 dpatch deapply-all
54 rm -rf debian/patched
55
56 install: build-apache2
57 dh_testdir
58 dh_testroot
59 dh_prep
60 find -name ".svn" -type d | xargs rm -rf
61 find -name ".git" -type d | xargs rm -rf
62 dh_installdirs
63 dh_install
64 docbook-to-man debian/suphp-common.manpage.sgml > debian/suphp-common/usr/share/man/man8/suphp.8
65 install -m 644 debian/suphp-common.lintian-override debian/suphp-common/usr/share/lintian/overrides/suphp-common
66 mv debian/suphp-common/etc/suphp/suphp.conf-example debian/suphp-common/etc/suphp/suphp.conf
67 mv debian/libapache2-mod-suphp/usr/lib/apache2/modules/mod_suphp.so.0.0.0 debian/libapache2-mod-suphp/usr/lib/apache2/modules/mod_suphp.so
68
69
70 # Build architecture-independent files here.
71 binary-indep:
72 # We have nothing to do by default.
73
74 # Build architecture-dependent files here.
75 binary-arch: install
76 dh_testdir
77 dh_testroot
78 # dh_installdebconf
79 dh_installdocs
80 mv debian/libapache2-mod-suphp/usr/share/doc/libapache2-mod-suphp/INSTALL debian/libapache2-mod-suphp/usr/share/doc/libapache2-mod-suphp/README
81 # dh_installexamples
82 # dh_installmenu
83 dh_installlogrotate
84 # dh_installemacsen
85 # dh_installpam
86 # dh_installmime
87 # dh_installinit
88 # dh_installcron
89 # dh_installman
90 # dh_installinfo
91 dh_installchangelogs ChangeLog
92 dh_link
93 dh_strip
94 dh_compress
95 dh_fixperms
96 chmod u+s debian/suphp-common/usr/lib/suphp/suphp
97 # dh_makeshlibs
98 dh_installdeb
99 # dh_perl
100 dh_shlibdeps
101 dh_gencontrol
102 dh_md5sums
103 dh_builddeb
104
105 binary: binary-indep binary-arch
106 .PHONY: configure build build-apache2 clean binary-indep binary-arch binary install patch unpatch