Depend on core packages, declare break against old hcoop-admin-common-config
[hcoop/zz_old/debian/hcoop-common-config.git] / debian / hcoop-common-config.postinst
1 #!/bin/sh
2 # postinst script for hcoop-apache2-config
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # <new-version>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 # dh_installdeb will replace this with shell code automatically
22 # generated by other debhelper scripts.
23
24 #DEBHELPER#
25
26 # We want to run last (need the diversions to be installed first)
27 case "$1" in
28 configure)
29 # It would be nice to use -d or something, but for whatever
30 # reason when adding and removing links in rcS insserv doesn't
31 # actually do anything unless you force remove the script
32 # first!
33 insserv -rf openafs-client
34 insserv openafs-client
35 ;;
36
37 abort-upgrade|abort-remove|abort-deconfigure)
38 ;;
39
40 *)
41 echo "postinst called with unknown argument \`$1'" >&2
42 exit 1
43 ;;
44 esac
45
46
47
48 exit 0