Configure suexec
[hcoop/zz_old/debian/hcoop-apache2-config.git] / debian / hcoop-apache2-config.postinst
1 #!/bin/sh
2 # postinst script for hcoop-apache2-config
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # <new-version>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 HCOOP_APACHE_MODULES="dav dav_fs dav_lock rewrite suexec suphp waklog"
22
23 case "$1" in
24 configure)
25
26 # Redundantly enable on upgrades in case some new modules were
27 # enabled
28 for mod in $HCOOP_APACHE_MODULES; do
29 a2enmod -q $mod
30 done
31
32 HCOOP_ENABLE_FAILED=0
33 for mod in $HCOOP_APACHE_MODULES; do
34 if [ ! -e "/etc/apache2/modules-enabled/${mod}.conf" ]; then
35 HCOOP_ENABLED_FAILED=1
36 fi
37 done
38
39 if [ ! $HCOOP_ENABLE_FAILED ]; then
40 invoke-rc.d apache2 restart
41 fi
42 ;;
43
44 abort-upgrade|abort-remove|abort-deconfigure)
45 ;;
46
47 *)
48 echo "postinst called with unknown argument \`$1'" >&2
49 exit 1
50 ;;
51 esac
52
53 # dh_installdeb will replace this with shell code automatically
54 # generated by other debhelper scripts.
55
56 #DEBHELPER#
57
58 exit 0