Move hcoop vhost config into sites-available
[hcoop/zz_old/debian/hcoop-apache2-config.git] / debian / hcoop-apache2-config.postinst
1 #!/bin/sh
2 # postinst script for hcoop-apache2-config
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 # <new-version>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 # make sure to keep in sync with prerm
22 HCOOP_APACHE_MODULES="auth_kerb cache dav dav_fs dav_lock disk_cache expires include mime_magic negotiation proxy proxy_http rewrite ssl status suexec suphp waklog"
23
24 case "$1" in
25 configure)
26
27 # Redundantly enable on upgrades in case some new modules were
28 # enabled
29 for mod in $HCOOP_APACHE_MODULES; do
30 a2enmod -q $mod
31 done
32
33 # Enable vhosts. This has to be in sites-enabled so that
34 # 000default is loaded before member vhosts
35 a2ensite hcoop-vhosts
36
37 HCOOP_ENABLE_FAILED=0
38 for mod in $HCOOP_APACHE_MODULES; do
39 if [ ! -e "/etc/apache2/modules-enabled/${mod}.load" ]; then
40 HCOOP_ENABLED_FAILED=1
41 fi
42 done
43
44 if [ ! $HCOOP_ENABLE_FAILED ]; then
45 invoke-rc.d apache2 restart
46 fi
47 ;;
48
49 abort-upgrade|abort-remove|abort-deconfigure)
50 ;;
51
52 *)
53 echo "postinst called with unknown argument \`$1'" >&2
54 exit 1
55 ;;
56 esac
57
58 # dh_installdeb will replace this with shell code automatically
59 # generated by other debhelper scripts.
60
61 #DEBHELPER#
62
63 exit 0