Imported Debian version 5.1.2
[hcoop/zz_old/debian/config-package-dev.git] / examples / cdbs / debathena-bin-example-1.1 / debian / rules
1 #!/usr/bin/make -f
2
3 DEB_DISPLACE_EXTENSION = .debathena
4 # Install wrapper scripts for /usr/bin/elinks and /usr/bin/less
5 DEB_DISPLACE_FILES_debathena-bin-example += \
6 /usr/bin/less.debathena
7
8 # If these had materially different behavior from the original
9 # versions, one might divert the man pages as well
10 DEB_DISPLACE_FILES_debathena-bin-example += /usr/share/man/man1/less.debathena.1.gz
11
12 # This isn't config-package-dev specific, but we may want to install symlinks instead.
13 DEB_DH_LINK_debathena-bin-example += \
14 /usr/share/man/man1/less.debathena-orig.1.gz /usr/share/man/man1/less.debathena.1.gz
15
16 # Remove elinks displacement on upgrade if it was previously in place on
17 # the target system
18 DEB_UNDISPLACE_FILES_debathena-bin-example += /usr/bin/elinks.debathena
19 # and the man page
20 DEB_UNDISPLACE_FILES_debathena-bin-example += /usr/share/man/man1/elinks.debathena.1.gz
21
22 include /usr/share/cdbs/1/rules/debhelper.mk
23 include /usr/share/cdbs/1/rules/config-package.mk