v1.03: tiny performance improvement, lots of commenting
[hcoop/debian/libnss-afs.git] / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9
10
11
12 CFLAGS = -Wall -g
13
14 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
15 CFLAGS += -O0
16 else
17 CFLAGS += -O2
18 endif
19 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20 INSTALL_PROGRAM += -s
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27
28 touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE)
38 #/usr/bin/docbook-to-man debian/libnss-afs.sgml > libnss-afs.1
39
40 touch build-stamp
41
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp configure-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) clean
49
50 dh_clean
51
52 install: build
53 dh_testdir
54 dh_testroot
55 dh_clean -k
56 dh_installdirs
57
58 # Add here commands to install the package into debian/libnss-afs.
59 mkdir -p $(CURDIR)/debian/libnss-afs
60 $(MAKE) install DESTDIR=$(CURDIR)/debian/libnss-afs
61 #install -m 644 default $(CURDIR)/debian/libnss-afs/etc/default/afsnssd
62
63 # Build architecture-independent files here.
64 binary-indep: build install
65 # We have nothing to do by default.
66
67 # Build architecture-dependent files here.
68 binary-arch: build install
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs
72 dh_installdocs
73 dh_installexamples
74 #dh_installinit -- start 52 S . stop 33 0 6 .
75 dh_installman
76 dh_link
77 dh_strip
78 dh_compress
79 dh_fixperms
80 dh_installdeb
81 dh_shlibdeps
82 dh_gencontrol
83 dh_md5sums
84 dh_builddeb
85
86 binary: binary-indep binary-arch
87 .PHONY: build clean binary-indep binary-arch binary install configure