debian: Fix doc file list and lintian issues
[hcoop/debian/libapache-mod-waklog.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
dissimilarity index 75%
index 1dd408c..f62e79b
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       chmod +x regen.sh
-       ./regen.sh
-       ./configure --with-afs-libs=/usr/lib/afs --with-afs-headers=/usr/include/afs
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE)
-       #docbook-to-man debian/libapache-mod-waklog.sgml > libapache-mod-waklog.1
-
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
-       dh_clean  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
-       dh_installdirs
-
-       # Add here commands to install the package into debian/libapache-mod-waklog.
-       mkdir -p debian/libapache-mod-waklog/usr/lib/apache/1.3/
-       mkdir -p debian/libapache-mod-waklog/etc/apache/conf.d/
-       cp mod_waklog.so debian/libapache-mod-waklog/usr/lib/apache/1.3/
-       cp debian/waklog.load debian/libapache-mod-waklog/etc/apache/conf.d/waklog.conf
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+CFLAGS = -Wall -g
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0
+else
+       CFLAGS += -O2
+endif
+
+build-apache2:
+       dh_testdir
+       chmod +x regen.sh
+       ./regen.sh
+       ./configure \
+         --with-afs-libs=/usr/lib/afs \
+         --with-afs-headers=/usr/include/afs \
+         --with-apxs=/usr/bin/apxs2
+       make clean
+       $(MAKE)
+       mv .libs/mod_waklog.so .; true
+       dh_installdirs
+       mkdir -p debian/libapache2-mod-waklog/usr/lib/apache2/modules/
+       mkdir -p debian/libapache2-mod-waklog/etc/apache2/mods-available
+       cp mod_waklog.so debian/libapache2-mod-waklog/usr/lib/apache2/modules/
+       cp debian/waklog.load debian/libapache2-mod-waklog/etc/apache2/mods-available
+       touch build-apache2
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -rf build-stamp .libs
+       [ ! -f Makefile ] || $(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) distclean
+       rm -f aclocal.m4 configure compile install-sh missing Makefile.in mod_waklog.la mod_waklog.so
+       dh_clean  --exclude ./_darcs/current/Makefile.orig --exclude ./Makefile.orig
+
+build: build-indep build-arch
+build-indep:
+build-arch: build-apache2
+
+binary: binary-indep binary-arch
+binary-indep: build-indep
+binary-arch: build-arch
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs 
+       dh_installdocs
+       dh_installexamples
+       dh_installman
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+.PHONY: build clean binary-indep binary-arch binary build-indep build-arch