Merge remote-tracking branch 'sf/master'
[hcoop/debian/libapache-mod-waklog.git] / mod_waklog.spec
1 Name: mod_waklog
2 Version: 1.1.0
3 Release: 1%{?dist}
4 Summary: Apache module allowing the web server to acquire AFS credentials
5
6 Group: System Environment/Daemons
7 License: University of Michigan
8 Vendor: Sine Nomine Associates
9 URL: http://sourceforge.net/projects/modwaklog/
10 Source0: http://sourceforge.net/projects/modwaklog/files/modwaklog/mod_waklog-%{version}.tgz
11 BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
12
13 BuildRequires: openafs-authlibs-devel httpd-devel apr-devel krb5-devel automake
14 Requires: httpd
15
16 %description
17 mod_waklog is an Apache module that provides aklog-like semantics
18 for the web. mod_waklog will acquire (and store in the kernel) an
19 AFS credential when a connection is opened, use the credential for
20 the duration of the connection, and will remove the credential when
21 the connection is closed.
22
23 %prep
24 %setup -q
25 # This goes away with a proper dist tarball; likewise BuildRequires: automake
26 ./regen.sh
27
28 %build
29 ./configure --libdir=%{_libdir} --with-afs-libs=%{_libdir}/afs
30 make %{?_smp_mflags}
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35 install -d $RPM_BUILD_ROOT%{_libdir}/httpd/modules/
36 install .libs/mod_waklog.so $RPM_BUILD_ROOT%{_libdir}/httpd/modules/
37
38 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/
39 install -m 644 waklog.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %{_libdir}/httpd/modules/mod_waklog.so
47 %config(noreplace) %{_sysconfdir}/httpd/conf.d/waklog.conf
48 %doc README COPYING AUTHORS NEWS
49
50 %changelog
51 * Wed Jul 15 2015 Jacob Welsh <jwelsh@sinenomine.net> - 1.1.0-1
52 - Initial RPM package