Merge branch 'debian'
[hcoop/debian/exim4.git] / debian / patches / 79_CVE-2017-1000369.patch
diff --git a/debian/patches/79_CVE-2017-1000369.patch b/debian/patches/79_CVE-2017-1000369.patch
deleted file mode 100644 (file)
index 87fb3b7..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-commit 65e061b76867a9ea7aeeb535341b790b90ae6c21
-Author: Heiko Schlittermann (HS12-RIPE) <hs@schlittermann.de>
-Date:   Wed May 31 23:08:56 2017 +0200
-
-    Cleanup (prevent repeated use of -p/-oMr to avoid mem leak)
-
-diff --git a/src/exim.c b/src/exim.c
-index 67583e5..88e1197 100644
---- a/src/exim.c
-+++ b/src/exim.c
-@@ -3106,7 +3106,14 @@ for (i = 1; i < argc; i++)
-       /* -oMr: Received protocol */
--      else if (Ustrcmp(argrest, "Mr") == 0) received_protocol = argv[++i];
-+      else if (Ustrcmp(argrest, "Mr") == 0)
-+
-+        if (received_protocol)
-+          {
-+          fprintf(stderr, "received_protocol is set already\n");
-+          exit(EXIT_FAILURE);
-+          }
-+        else received_protocol = argv[++i];
-       /* -oMs: Set sender host name */
-@@ -3202,7 +3209,15 @@ for (i = 1; i < argc; i++)
-     if (*argrest != 0)
-       {
--      uschar *hn = Ustrchr(argrest, ':');
-+      uschar *hn;
-+
-+      if (received_protocol)
-+        {
-+        fprintf(stderr, "received_protocol is set already\n");
-+        exit(EXIT_FAILURE);
-+        }
-+
-+      hn = Ustrchr(argrest, ':');
-       if (hn == NULL)
-         {
-         received_protocol = argrest;