Import Debian changes 4.89-2+deb9u3~bpo8+1
[hcoop/debian/exim4.git] / debian / patches / 35_install.dpatch
1 Description: Exim's installation scripts install the binary as
2 exim-<version> - disable this feature.
3 Author: Andreas Metzler <ametzler@debian.org>
4 Origin: vendor
5 Forwarded: not-needed
6 Last-Update: 2016-09-25
7
8 --- a/scripts/exim_install
9 +++ b/scripts/exim_install
10 @@ -221,6 +221,8 @@ while [ $# -gt 0 ]; do
11 version=exim-`$exim 2>/dev/null | \
12 awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
13
14 + version=exim
15 +
16 if [ "${version}" = "exim-${EXE}" ]; then
17 echo $com ""
18 echo $com "*** Could not run $exim to find version number ***"
19 @@ -370,10 +372,8 @@ done
20
21
22
23 -# If there is no configuration file, install the default, modifying it to refer
24 -# to the configured system aliases file. If there is no setting for
25 -# SYSTEM_ALIASES_FILE, use the traditional /etc/aliases. If the file does not
26 -# exist, install a default (dummy) for that too.
27 +# Install default configuration file
28 +# This is a local Debian modification.
29
30 # However, if CONFIGURE_FILE specifies a list of files, skip this code.
31
32 @@ -396,7 +396,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
33 ${real} ${MKDIR} -p `${DIRNAME} ${CONFIGURE_FILE}`
34
35 echo sed -e '\\'
36 - echo " \"/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'${ACTUAL_SYSTEM_ALIASES_FILE}'\"" '\\'
37 + echo " \"/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/aliases'\"" '\\'
38 echo " ../src/configure.default > \${CONFIGURE_FILE}"
39
40 # I can't find a way of writing this using the ${real} feature because
41 @@ -405,7 +405,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
42
43 if [ "$real" = "" ] ; then
44 sed -e \
45 - "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'${ACTUAL_SYSTEM_ALIASES_FILE}'" \
46 + "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/aliases'" \
47 ../src/configure.default > ${CONFIGURE_FILE}
48 else
49 true