Import Debian changes 4.92-8+deb10u4
[hcoop/debian/exim4.git] / debian / patches / 75_13-Use-dsn_from-for-success-DSN-messages.-Bug-2404.patch
1 From 454bab46ae6812e29652d10c390451c962a6f806 Mon Sep 17 00:00:00 2001
2 From: Jeremy Harris <jgh146exb@wizmail.org>
3 Date: Tue, 4 Jun 2019 18:13:21 +0100
4 Subject: [PATCH 2/2] Use dsn_from for success-DSN messages. Bug 2404
5
6 (cherry picked from commit 87abcb247b4444bab5fd0bcb212ddb26d5fd9191)
7 ---
8 doc/ChangeLog | 4 ++++
9 src/deliver.c | 4 ++--
10 2 files changed, 6 insertions(+), 2 deletions(-)
11
12 diff --git a/doc/ChangeLog b/doc/ChangeLog
13 index 5a3e453d..1a12c014 100644
14 --- a/doc/ChangeLog
15 +++ b/doc/ChangeLog
16 @@ -65,6 +65,10 @@ JH/20 Bug 2389: fix server advertising of usable certificates, under GnuTLS in
17 directory-of-certs mode. Previously they were advertised despite the
18 documentation.
19
20 +JH/27 Bug 2404: Use the main-section configuration option "dsn_from" for
21 + success-DSN messages. Previously the From: header was always the default
22 + one for these; the option was ignored.
23 +
24
25 Exim version 4.92
26 -----------------
27 diff --git a/src/deliver.c b/src/deliver.c
28 index e1799411..4720f596 100644
29 --- a/src/deliver.c
30 +++ b/src/deliver.c
31 @@ -7365,8 +7365,8 @@ if (addr_senddsn)
32 if (errors_reply_to)
33 fprintf(f, "Reply-To: %s\n", errors_reply_to);
34
35 + moan_write_from(f);
36 fprintf(f, "Auto-Submitted: auto-generated\n"
37 - "From: Mail Delivery System <Mailer-Daemon@%s>\n"
38 "To: %s\n"
39 "Subject: Delivery Status Notification\n"
40 "Content-Type: multipart/report; report-type=delivery-status; boundary=%s\n"
41 @@ -7377,7 +7377,7 @@ if (addr_senddsn)
42
43 "This message was created automatically by mail delivery software.\n"
44 " ----- The following addresses had successful delivery notifications -----\n",
45 - qualify_domain_sender, sender_address, bound, bound);
46 + sender_address, bound, bound);
47
48 for (addr_dsntmp = addr_senddsn; addr_dsntmp;
49 addr_dsntmp = addr_dsntmp->next)
50 --
51 2.20.1
52