Import Debian changes 4.92-8+deb10u4
[hcoop/debian/exim4.git] / debian / patches / 60_convert4r4.dpatch
1 Description: Add a warning message to convert4r4
2 Author: Marc Haber <mh+debian-packages@zugschlus.de>
3 Origin: vendor
4 Forwarded: no
5 Last-Update: 2013-09-28
6
7 --- a/src/convert4r4.src
8 +++ b/src/convert4r4.src
9 @@ -666,6 +666,32 @@ return defined $main{$_[0]} && $main{$_[
10
11 print STDERR "Runtime configuration file converter for Exim release 4.\n";
12
13 +if( !defined $ENV{"CONVERT4R4"} || $ENV{"CONVERT4R4"} ne "I understand this is an unsupported tool" ) {
14 +
15 + print STDERR <<EOF;
16 +convert4r4 on Debian GNU/Linux deprecated
17 +
18 +This tool is unsupported by upstream and discouraged by the Debian Exim 4
19 +maintainers. It has multiple known bugs, and you need to manually
20 +review its output after using it anyway. Please seriously consider complete
21 +manual regeneration of the Exim 4 configuration, preferably by using the new
22 +Debconf interface to Exim 4.
23 +
24 +If you decide to ignore this advice and to use this script anyway,
25 +setting the environment variable CONVERT4R4 to the value
26 +\"I understand this is an unsupported tool\"
27 +will allow you to run the script. If you find bugs, you get to keep
28 +the pieces. Please do not file bugs against this script in the Debian
29 +BTS without providing a patch fixing the bugs, and please do not
30 +expect the upstream exim-users mailing list to answer questions.
31 +
32 +Kind regards
33 +the Debian Exim4 Maintainers
34 +EOF
35 +
36 + exit 1;
37 +}
38 +
39 $transport_start = $director_start = $router_start = $retry_start
40 = $rewrite_start = $auth_start = 999999;
41