Merge branch 'debian'
[hcoop/debian/exim4.git] / debian / patches / 67_unnecessaryCopt.diff
1 Description: Stop using exim's -C option in utility scripts (exiwhat
2 et al.) since this breaks with ALT_CONFIG_PREFIX.
3 Author: Andreas Metzler <ametzler@downhill.at.eu.org>
4 Forwarded: http://bugs.exim.org/show_bug.cgi?id=1045
5 Last-Update: 2014-12-01
6
7 --- a/src/exicyclog.src
8 +++ b/src/exicyclog.src
9 @@ -146,10 +146,10 @@ st=' '
10 exim_path=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
11 if test "$exim_path" = ""; then exim_path=BIN_DIRECTORY/exim4; fi
12
13 -spool_directory=`$exim_path -C $config -bP spool_directory | sed 's/.*=[ ]*//'`
14 +spool_directory=`$exim_path -bP spool_directory | sed 's/.*=[ ]*//'`
15
16 if [ "$log_file_path" = "" ] ; then
17 - log_file_path=`$exim_path -C $config -bP log_file_path | sed 's/.*=[ ]*//'`
18 + log_file_path=`$exim_path -bP log_file_path | sed 's/.*=[ ]*//'`
19 fi
20
21 # If log_file_path contains only "syslog" then no Exim log files are in use.
22 --- a/src/eximon.src
23 +++ b/src/eximon.src
24 @@ -74,8 +74,8 @@ st=' '
25 EXIM_PATH=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
26 if test "$EXIM_PATH" = ""; then EXIM_PATH=BIN_DIRECTORY/exim4; fi
27
28 -SPOOL_DIRECTORY=`$EXIM_PATH -C $config -bP spool_directory | sed 's/.*=[ ]*//'`
29 -LOG_FILE_PATH=`$EXIM_PATH -C $config -bP log_file_path | sed 's/.*=[ ]*//'`
30 +SPOOL_DIRECTORY=`$EXIM_PATH -bP spool_directory | sed 's/.*=[ ]*//'`
31 +LOG_FILE_PATH=`$EXIM_PATH -bP log_file_path | sed 's/.*=[ ]*//'`
32
33 # If log_file_path is "syslog" then logging is only to syslog, and the monitor
34 # is unable to display a log tail unless EXIMON_LOG_FILE_PATH is set to tell
35 --- a/src/exinext.src
36 +++ b/src/exinext.src
37 @@ -91,8 +91,8 @@ if [ "$exim_path" = "" ]; then
38 fi
39
40 if test "$exim_path" = ""; then exim_path=BIN_DIRECTORY/exim4; fi
41 -spool_directory=`$exim_path $eximmacdef -C $config -bP spool_directory | sed 's/.*=[ ]*//'`
42 -qualify_domain=`$exim_path $eximmacdef -C $config -bP qualify_domain | sed 's/.*=[ ]*//'`
43 +spool_directory=`$exim_path $eximmacdef -bP spool_directory | sed 's/.*=[ ]*//'`
44 +qualify_domain=`$exim_path $eximmacdef -bP qualify_domain | sed 's/.*=[ ]*//'`
45
46 # Now do the job. Perl uses $ so frequently that we don't want to have to
47 # escape them all from the shell, so pass in shell variable values as
48 @@ -134,7 +134,7 @@ perl - $exim_path "$eximmacdef" $argone
49 # Run Exim to get a list of hosts for the given domain; for
50 # each one construct the appropriate retry key.
51
52 - open(LIST, "$exim -C $config -v -bt $address |") ||
53 + open(LIST, "$exim -v -bt $address |") ||
54 die "can't run exim to route $address";
55
56 while (<LIST>)
57 --- a/src/exiwhat.src
58 +++ b/src/exiwhat.src
59 @@ -89,8 +89,8 @@ fi
60 st=' '
61 exim_path=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
62 if test "$exim_path" = ""; then exim_path=BIN_DIRECTORY/exim4; fi
63 -spool_directory=`$exim_path -C $config -bP spool_directory | sed "s/.*=[ ]*//"`
64 -process_log_path=`$exim_path -C $config -bP process_log_path | sed "s/.*=[ ]*//"`
65 +spool_directory=`$exim_path -bP spool_directory | sed "s/.*=[ ]*//"`
66 +process_log_path=`$exim_path -bP process_log_path | sed "s/.*=[ ]*//"`
67
68 # The file that Exim writes when sent the SIGUSR1 signal is specified by
69 # the process_log_path option. If that is not defined, Exim uses the file