Import Debian changes 4.92-8+deb10u6
[hcoop/debian/exim4.git] / debian / patches / 84_29-Fix-BDAT-issue-for-body-w-o-trailing-CRLF-again-Bug-.patch
1 From 5220dc30120bd79319d465bd7a6e4b21a0881f9a Mon Sep 17 00:00:00 2001
2 From: "Heiko Schlittermann (HS12-RIPE)" <hs@schlittermann.de>
3 Date: Fri, 30 Apr 2021 10:47:45 +0200
4 Subject: [PATCH 29/29] Fix BDAT issue for body w/o trailing CRLF (again Bug
5 1974)
6
7 (cherry picked from commit 919111edac911ba9c15422eafd7c5bf14d416d26)
8 ---
9 src/smtp_in.c | 1 +
10 1 file changed, 1 insertion(+)
11
12 diff --git a/src/smtp_in.c b/src/smtp_in.c
13 index 016c44c0f..76784c15f 100644
14 --- a/src/smtp_in.c
15 +++ b/src/smtp_in.c
16 @@ -854,6 +854,7 @@ int
17 bdat_ungetc(int ch)
18 {
19 chunking_data_left++;
20 +bdat_push_receive_functions(); /* we're not done yet, calling push is safe, because it checks the state before pushing anything */
21 return lwr_receive_ungetc(ch);
22 }
23
24 --
25 2.30.2
26