Import Debian changes 4.92-8+deb10u6
[hcoop/debian/exim4.git] / debian / patches / 84_17-Security-Always-exit-when-LOG_PANIC_DIE-is-set.patch
1 From 9b1ba71e66d18b1ae185e4d83788dc913f903a56 Mon Sep 17 00:00:00 2001
2 From: Qualys Security Advisory <qsa@qualys.com>
3 Date: Sun, 21 Feb 2021 22:09:06 -0800
4 Subject: [PATCH 17/29] Security: Always exit when LOG_PANIC_DIE is set
5
6 ---
7 src/log.c | 1 +
8 1 file changed, 1 insertion(+)
9
10 diff --git a/src/log.c b/src/log.c
11 index d08200044..c8313890e 100644
12 --- a/src/log.c
13 +++ b/src/log.c
14 @@ -894,6 +894,7 @@ if (!(flags & (LOG_MAIN|LOG_PANIC|LOG_REJECT)))
15 if (f.disable_logging)
16 {
17 DEBUG(D_any) debug_printf("log writing disabled\n");
18 + if ((flags & LOG_PANIC_DIE) == LOG_PANIC_DIE) exim_exit(EXIT_FAILURE, NULL);
19 return;
20 }
21
22 --
23 2.30.2
24