Import Debian changes 4.89-2+deb9u4
[hcoop/debian/exim4.git] / debian / patches / 78_Disable-chunking-BDAT-by-default.patch
1 Description: Disable chunking (BDAT) by default.
2 Change default value of main option chunking_advertise_hosts and smtp
3 transport option hosts_try_chunking from "*" to empty.
4 Author: Andreas Metzler <ametzler@debian.org>
5 Origin: vendor
6 Forwarded: not-needed
7 Last-Update: 2017-01-19
8
9 --- a/doc/spec.txt
10 +++ b/doc/spec.txt
11 @@ -13215,9 +13215,9 @@ There is a slight performance penalty fo
12 preceding 4.88 had these disabled by default; high-rate installations confident
13 they will never run out of resources may wish to deliberately disable them.
14
15 -+--------------------------------------------------------------+
16 -|chunking_advertise_hosts|Use: main|Type: host list*|Default: *|
17 -+--------------------------------------------------------------+
18 ++------------------------------------------------------------------+
19 +|chunking_advertise_hosts|Use: main|Type: host list*|Default: unset|
20 ++------------------------------------------------------------------+
21
22 The CHUNKING extension (RFC3030) will be advertised in the EHLO message to
23 these hosts. Hosts may use the BDAT command as an alternate to DATA.
24 @@ -22522,9 +22522,9 @@ connects. If authentication fails, Exim
25 unauthenticated. See also hosts_require_auth, and chapter 33 for details of
26 authentication.
27
28 -+--------------------------------------------------------+
29 -|hosts_try_chunking|Use: smtp|Type: host list*|Default: *|
30 -+--------------------------------------------------------+
31 ++------------------------------------------------------------+
32 +|hosts_try_chunking|Use: smtp|Type: host list*|Default: unset|
33 ++------------------------------------------------------------+
34
35 This option provides a list of servers to which, provided they announce
36 CHUNKING support, Exim will attempt to use BDAT commands rather than DATA. BDAT
37 --- a/src/globals.c
38 +++ b/src/globals.c
39 @@ -498,7 +498,7 @@ BOOL check_rfc2047_length = TRUE;
40 int check_spool_inodes = 100;
41 int check_spool_space = 10*1024; /* 10K Kbyte == 10MB */
42
43 -uschar *chunking_advertise_hosts = US"*";
44 +uschar *chunking_advertise_hosts = NULL;
45 unsigned chunking_datasize = 0;
46 unsigned chunking_data_left = 0;
47 BOOL chunking_offered = FALSE;
48 --- a/src/transports/smtp.c
49 +++ b/src/transports/smtp.c
50 @@ -200,7 +200,7 @@ smtp_transport_options_block smtp_transp
51 NULL, /* serialize_hosts */
52 NULL, /* hosts_try_auth */
53 NULL, /* hosts_require_auth */
54 - US"*", /* hosts_try_chunking */
55 + NULL, /* hosts_try_chunking */
56 #ifdef EXPERIMENTAL_DANE
57 NULL, /* hosts_try_dane */
58 NULL, /* hosts_require_dane */