Import Debian changes 4.92-8+deb10u3
[hcoop/debian/exim4.git] / debian / patches / 75_15-Fix-detection-of-32b-platform-at-build-time.-Bug-240.patch
1 From 26dd3aa007b3b77969610c031f59388e0953bd00 Mon Sep 17 00:00:00 2001
2 From: Jeremy Harris <jgh146exb@wizmail.org>
3 Date: Fri, 7 Jun 2019 11:54:10 +0100
4 Subject: [PATCH 2/2] Fix detection of 32b platform at build time. Bug 2405
5
6 ---
7 src/buildconfig.c | 12 +++---
8 test/scripts/0000-Basic/0002 | 72 +++++++++++++++++++-----------------
9 test/stdout/0002 | 72 +++++++++++++++++++-----------------
10 3 files changed, 83 insertions(+), 73 deletions(-)
11
12 diff --git a/src/buildconfig.c b/src/buildconfig.c
13 index 71cf97b1..a680b344 100644
14 --- a/src/buildconfig.c
15 +++ b/src/buildconfig.c
16 @@ -111,6 +111,7 @@ unsigned long test_ulong_t = 0L;
17 unsigned int test_uint_t = 0;
18 #endif
19 long test_long_t = 0;
20 +long long test_longlong_t = 0;
21 int test_int_t = 0;
22 FILE *base;
23 FILE *new;
24 @@ -155,15 +156,16 @@ This assumption is known to be OK for the common operating systems. */
25
26 fprintf(new, "#ifndef OFF_T_FMT\n");
27 if (sizeof(test_off_t) > sizeof(test_long_t))
28 - {
29 fprintf(new, "# define OFF_T_FMT \"%%lld\"\n");
30 - fprintf(new, "# define LONGLONG_T long long int\n");
31 - }
32 else
33 - {
34 fprintf(new, "# define OFF_T_FMT \"%%ld\"\n");
35 +fprintf(new, "#endif\n\n");
36 +
37 +fprintf(new, "#ifndef LONGLONG_T\n");
38 +if (sizeof(test_longlong_t) > sizeof(test_long_t))
39 + fprintf(new, "# define LONGLONG_T long long int\n");
40 +else
41 fprintf(new, "# define LONGLONG_T long int\n");
42 - }
43 fprintf(new, "#endif\n\n");
44
45 /* Now do the same thing for time_t variables. If the length is greater than
46 --
47 2.20.1
48